Opened 8 years ago

Closed 8 years ago

#4952 closed Bug (fixed)

[IE] Editing table creates a new table

Reported by: Damian Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: 3.0.2
Keywords: IBM Confirmed IE Review+ Cc:

Description (last modified by Frederico Caldeira Knabben)

To reproduce:

  1. Open nightly demo
  2. Create default table
  3. Edit the table

Notice that a new table is created.

Attachments (1)

4952.patch (809 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Tobiasz Cudnik

Keywords: Pending added

If step 3 "Edit the table" was meant by using table toolbar button, then it looks like duplicate of #4635 "Unable to open property dialog for existing table from toolbar" which is invalid, due to possibility of nested tables.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1
Priority: HighNormal

Other than #4635, it may be a duplicate of #4948. Can you confirm it?

comment:3 Changed 8 years ago by Damian

Step 3. Should be refined. It means right-click on any cell in the newly created table and select "Table Properties".

I think the problem is down to selections. When you first left-click into the cell then right-click, it works OK. But if you have the cursor outside the table and then you right-click into a cell, the correct context menu (and properties dialog) comes up but the cursor moves out of the table. So when you click OK, the dialog creates a new table, usually above the table that was being edited.

Reproduced in IE 7.

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added; Pending removed
Milestone: CKEditor 3.1
Version: 3.0.2

Confirmed regression with IE8 also. This is definitely a selection issue. No problem with FF.

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Issue introduced with [4521].

Changed 8 years ago by Garry Yao

Attachment: 4952.patch added

comment:6 Changed 8 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

The patch simply revert [4521] as #4041 is not any more reproduced, probably fixed by recent selection related fixings.

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Review+ added; Review? removed

comment:8 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4876].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy