Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5003 closed Bug (duplicate)

The anti-cache timestamp is not applied on a few critical files.

Reported by: Niek Kouwenberg Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1
Keywords: Cc:

Description

I've recently had some trouble with clients getting Javascript errors after I've updated CKEditor to 3.0.2. Now with 3.1, I don't want the same trouble, so I investigated the anti-cache functionality.

I include the CKEditor in the proper way, and most files do get the anti-cache timestamp, but a few critical ones don't. The two criticals I have had problems with are custom plugins, and skins.

Timestamp ommited when loading a custom plugin

I have a custom plugin for CKEditor, which I used to include like below.

CKEDITOR.plugins.addExternal('myplugin', 'ckeditor/plugins/myplugin/');

You can see I ommited the filename, making it default to 'plugin.js'. However, doing so, the anti-cache timestamp is not appended to the file name. When I define the filename like blow, the timestamp IS added.

CKEDITOR.plugins.addExternal('myplugin', 'ckeditor/plugins/myplugin/', 'plugin.js');

I reckon the timestamp should also be appended when using a 'default' filename, not only when I define it manually.

Timestamp not appended to my skin

The anti-cache timestamp is never appended to the skin filename. Even if I use one of the three CKEditor skins, or use my own custom skin, no timestamp appended.

In core/skins.js on line 197, you can see the following code:

CKEDITOR.scriptLoader.load( skinPath + 'skin.js', function()
{
	loadPart( editor, skinName, skinPart, callback );
});

No timestamp, whereas a simple change can solve the caching problems:

CKEDITOR.scriptLoader.load( skinPath + 'skin.js?t=' + CKEDITOR.timestamp, function()

Change History (4)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.xCKEditor 3.3

comment:2 Changed 10 years ago by Niek Kouwenberg

The skin part was fixed with ticket #5030 (changeset [4948]).

This just leaves the plugin-timestamp to be fixed.

comment:3 Changed 10 years ago by Minh Nguyen

Milestone: CKEditor 3.3
Resolution: duplicate
Status: newclosed

dup of #5030

comment:4 Changed 10 years ago by Niek Kouwenberg

Only the skin part is a duplicate of that ticket.

The first part of my ticket, about the timestamp not being appended to plugin files, still stands.

I think this ticket should be reopened. (I won't do this myself, because previously this was not appreciated)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy