Opened 9 years ago

Closed 6 years ago

#5004 closed New Feature (wontfix)

Create accessibility plugin

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone:
Component: Accessibility Version:
Keywords: Confirmed Cc:

Description (last modified by Garry Yao)

ARIA is still not fully supported in browsers and screen readers. We still want to have the editor accessible with some old technologies, these should have a dedicated plugin for all the backwards (hacks) compatibility. It would make the necessary changes to the editor structure to make it accessible on some situations. It should be optional, loaded only when needed.

Change History (6)

comment:1 Changed 9 years ago by Garry Yao

Description: modified (diff)
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 9 years ago by Garry Yao

Changes are checked in with [4925] on aria branch.

comment:3 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5092] in 3.2.x branch.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.x
Resolution: fixed
Status: closedreopened

The last test results with ARIA support on core showed that we actually have quite few issues with non ARIA browsers. Actually, ARIA is bringing better support even on those browsers. Because of this we still need to understand the effective benefit of the compatibility plugin.

For now, I've removed the plugin with [5174]. We need to make more testing and research before considering proposing it again.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:6 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: reopenedclosed

I think that this issue expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy