Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#5091 closed Bug (fixed)

Domain relaxation partially broken in FF

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.2
Component: General Version: 3.1
Keywords: Oracle, Confirmed Review+ Cc: senthil.kumaran@…

Description

Under some conditions, FF is throwing this error:

Permission denied for <http://dev.ckeditor.local:8080> (document.domain has not been set) to get property Window.document from <http://dev.ckeditor.local:8080> (document.domain=<http://ckeditor.local>).

(confirmed in FF 3.5.7).

It seems that this bug has been introduced when fixing #4514. Reverting [4492] removes that particular error.

Steps to reproduce

Attachments (1)

5091.patch (960 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2

Let's see if we're able to have it done for the 3.2.

comment:2 Changed 8 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

First of all I can't reproduce the bug by following the above steps.

While Wiktor's finding here clue me in another TC which breaks the editor easily: load the editor inside a cross-domain frame, see ticket TC for details:
run OR view source.

[4492] has introduced a pretty nasty piece of window.top where all bugs root from, the problem is that we should never assuming a domain friendly environment.
Back to the original purpose of that codes was to make sure the fix also applied in case editor was placed inside a frame. But by further checking it today, I found the B/F cache doesn't even impact the iframe page at all, so we could safely scope #4514 to host page only.

Changed 8 years ago by Garry Yao

Attachment: 5091.patch added

comment:3 Changed 8 years ago by Garry Yao

As states above, 5091.patch is assumed to be resolving both the problem in ticket description and the one in my comment.

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5046].

comment:6 Changed 8 years ago by Senthil

Cc: senthil.kumaran@… added

comment:7 Changed 7 years ago by Senthil

Keywords: Oracle added
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy