Opened 8 years ago

Closed 7 years ago

#5237 closed Bug (fixed)

English text in dialogs' title is flipped when using RTL language

Reported by: Sa'ar Zac Elias Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.2
Component: UI : Language Version: 3.1
Keywords: IE Cc:

Description

To reproduce

  • Go to the demo and open the multi language interface.
  • Choose RTL language (i.e Hebrew)
  • Click on the 'Help' button for example.

Notice that the product name in the dialog title is flipped.

Attachments (3)

5237.patch (1.6 KB) - added by Dekel 8 years ago.
5237_2.patch (905 bytes) - added by Garry Yao 8 years ago.
5237_3.patch (868 bytes) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Language
Keywords: Confirmed IE added
Milestone: CKEditor 3.3

Confirmed with IE only.

We had issues with CSS in IE and because of this we were forced to make some "weird" things with dialog titles (weird solutions for weird browsers!). Because of this, ltr words are reverted.

We have solved this problem in the About dialog. In fact you can see that it works well for the Arabic language.

To make it work with Hebrew, it's enough to change the following entry in the about section of the language file:

dlgTitle : 'אודות rotidEKC',

But ok, this fixes the About dialog. Do you see any other dialog that needs fixes?

comment:2 Changed 8 years ago by Sa'ar Zac Elias

Umm, SCAYT plugin for example.
I have recently translated everything and you applied it to the 3.2 version, so after this release i'll have a better look on that one.
Anyway, i think it should be fixed in the CSS for further compatibility

comment:3 in reply to:  2 Changed 8 years ago by Frederico Caldeira Knabben

Replying to Saare:

Anyway, i think it should be fixed in the CSS for further compatibility

I think so also... but really I remember we've spent a lot of time on this issue. If I recall it well it was breaking the dialog dragging in the title area with IE.

comment:4 Changed 8 years ago by Sa'ar Zac Elias

OK, in Hebrew the problem is in all the SCAYT dialog (btw is there a way to translate the options inside of them?), Div container and About dialog.

comment:5 Changed 8 years ago by Sa'ar Zac Elias

Oh, and the new 'Accessibility instructions' dialog.

comment:6 in reply to:  5 Changed 8 years ago by Frederico Caldeira Knabben

Replying to Saare:

Oh, and the new 'Accessibility instructions' dialog.

Isn't it translatable? I mean, do you leave it in English for the Hebrew language?

comment:7 Changed 8 years ago by Sa'ar Zac Elias

Oops.. yes, i'll also translate this plugin with all the other language phrases that are to be translated, targeted to the 3.3 version release.
Anyway, if the problem is with the dragging, maybe if you cover the dialog title with a transparent DIV it will work OK.

Changed 8 years ago by Dekel

Attachment: 5237.patch added

comment:8 Changed 8 years ago by Dekel

This problem should be resolved using CSS Only! patch attached.

comment:9 Changed 8 years ago by Garry Yao

Keywords: Pending added; Confirmed removed

I'm curious which browser do you have this reproduced? WFM in both IE7 and IE8.

comment:10 in reply to:  1 Changed 8 years ago by Sa'ar Zac Elias

IE8. If you check this bug with Arabic in About dialog you will not observe this issue, as Fred wrote.

Changed 8 years ago by Garry Yao

Attachment: 5237_2.patch added

comment:11 Changed 8 years ago by Garry Yao

Keywords: Confirmed Review? added; Pending removed
Owner: set to Garry Yao
Status: newassigned

but really I remember we've spent a lot of time on this issue. If I recall it well it was breaking >the dialog dragging in the title area with IE.

WFM in all IEs, I would revert the original hacks unless it's proved to be necessary.

comment:12 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Much probably, the old hack is not anymore necessary because of the recent dialog structure changes.

comment:13 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5454].

comment:14 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Confirmed Review+ removed
Milestone: CKEditor 3.3CKEditor 3.4.2
Resolution: fixed
Status: closedreopened

The same fix must be ported to other skins as well.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5237_3.patch added

comment:15 Changed 7 years ago by Sa'ar Zac Elias

Owner: changed from Garry Yao to Sa'ar Zac Elias
Status: reopenedreview

comment:16 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_passed

comment:17 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5897].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy