Opened 8 years ago

Closed 8 years ago

#5278 closed Bug (fixed)

Link Dialog / Popup Name / Add validation to check for bad window names

Reported by: Russ Tennant Owned by: Minh Nguyen
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.2
Keywords: Confirmed IE Review+ Cc:

Description

Add validation to check for bad window names.

For example, if you type in a name with spaces it will not work in MSIE.

To reproduce in MSIE:

* Create a Link to "http://google.com"
* In the link dialog.
** Go to the target tab and select <popup window> as a target
** Type in "one two" as the Popup Window Name without the quotes.
* Press OK in the Link dialog.
* Preview the content. 
* Click the google link in the preview.
* The link is expected to open in a new window / window as named. Instead the link opens in the current window.

Attachments (2)

5278.patch (1.6 KB) - added by Minh Nguyen 8 years ago.
5278_2.patch (485 bytes) - added by Minh Nguyen 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by Minh Nguyen

Keywords: Confirmed IE added

Changed 8 years ago by Minh Nguyen

Attachment: 5278.patch added

comment:2 Changed 8 years ago by Minh Nguyen

Keywords: Review? added
Milestone: CKEditor 3.3
Owner: set to Minh Nguyen
Status: newassigned
Version: 3.2

comment:3 Changed 8 years ago by Minh Nguyen

Type: New FeatureBug

comment:4 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

Instead of giving a warning I would rather do it automatically like in V2:

	var sWindowName = "'" + GetE('txtPopupName').value.replace(/\W/gi, "") + "'" ;

We know what the problem is, so we should handle it automatically without any extra job from the user.

comment:5 Changed 8 years ago by Minh Nguyen

Thank alfonsoml's advice.

Changed 8 years ago by Minh Nguyen

Attachment: 5278_2.patch added

comment:6 Changed 8 years ago by Minh Nguyen

Keywords: Review? added; Review- removed

comment:7 Changed 8 years ago by Garry Yao

I would vote for Minh's original approach, the auto fixing looks strange.

comment:8 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

After talking with Garry he agreed that we can use the new approach.

comment:9 Changed 8 years ago by Minh Nguyen

Resolution: fixed
Status: assignedclosed

Fixed with [5237].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy