Ticket #5320 (closed Bug: invalid)

Opened 4 years ago

Last modified 4 years ago

Problems with &quote;

Reported by: iulian Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version:
Keywords: Cc: iulian_ilea@…

Description

Steps to reproduce:

  1. Copy this code into a HTML page as the content of a CKEditor:

<object data="http://ii/ckeditor/plugins/flowplayer/flowplayer-3.1.5.swf" height="344" type="application/x-shockwave-flash" width="425"><param name="movie" value="http://ii/ckeditor/plugins/flowplayer/flowplayer-3.1.5.swf" /><param name="allowfullscreen" value="true" /><param name="allowscriptaccess" value="always" /><param name="flashvars" value="config={&quot;clip&quot;:{&quot;url&quot;:&quot;http://flashy.flowplayer.org/video/flowplayer-700.flv&quot;,&quot;autoPlay&quot;:false}}" /></object>

  1. Open the page in a browser. When the CKEditor is loaded switch to "Source". It results in an invalid HTML code:

<object data="http://ii/ckeditor/plugins/flowplayer/flowplayer-3.1.5.swf" height="344" type="application/x-shockwave-flash" width="425"><param name="movie" value="http://ii/ckeditor/plugins/flowplayer/flowplayer-3.1.5.swf" /><param name="allowfullscreen" value="true" /><param name="allowscriptaccess" value="always" /><param :="" autoplay="" clip="" flashy.flowplayer.org="" flowplayer-700.flv="" http:="" name="flashvars" url="" value="config={" video="" /></object>

Change History

comment:1 Changed 4 years ago by fredck

  • Status changed from new to closed
  • Priority changed from High to Normal
  • Resolution set to worksforme
  • Keywords &quote removed

It works for me with CKEditor 3.2 in both FF and IE.

comment:2 Changed 4 years ago by iulian

  • Status changed from closed to reopened
  • Cc iulian_ilea@… added
  • Resolution worksforme deleted

Hi,

I am also using the latest version. I have posted a URL where the error happens: http://sp2.ro/368130

Also see the source code.

comment:3 Changed 4 years ago by fredck

  • Status changed from reopened to closed
  • Resolution set to invalid

This is a basic mistake when integrating the editor. As we can see in the demo page, you're loading the raw data inside the <textarea> tag, instead of "html encoding" it first.

Just look at our samples. You'll see that the sample text doesn't start with <p> but with &lt;p&gt;. The same thing must be done with your data when loading it, in this way the &quot; entities will be transformed into &amp;quot;, remaining unchanged by the browsers.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy