Opened 9 years ago

Closed 8 years ago

#5506 closed Bug (duplicate)

can't use right arrow key to bypass the form elements ( checkbox or radio)

Reported by: brooks Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: Cc:

Description

when the last element of the edit doc is checkbox or radio, can't bypass it use right arrow key. that means we can't add content after the form element.


reproduce

  1. enter this code in source view.
    <p>test<input name="ddd" type="checkbox" /></p>
    
  1. turn to WYSIWYG mode,and press right arrow key to reach the position after checkbox.

expect result: the cursor is blinking after checkbox
real result: the cursor only can reach the position before checkbox,we can't go further any more.

confirmed in

  1. win7, IE8 mode( IE8 compatible mode is ok )
  2. win7, firefox2.0 ( firefox3.5 is available,thought can't let the cursor blinking after checkbox, but you can add content after it)

Change History (3)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:2 Changed 8 years ago by Jakub Ś

This is a duplicate of #3513.

comment:3 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy