Opened 7 years ago

Closed 7 years ago

#5674 closed Bug (fixed)

SCAYT error on editor destroy

Reported by: WebSpellChecker.net Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version:
Keywords: Confirmed Review+ Cc: WebSpellChecker.net

Description (last modified by Alfonso Martínez de Lizarrondo)

Turn on scayt autostartup on sample page divreplace.html

Edit 1-st text block by double clicking, wait scayt run

Edit 2-nd text block:

error occurs:

plugin.getScayt() is null or not an object

Attachments (3)

5674.patch (1.3 KB) - added by WebSpellChecker.net 7 years ago.
add check of SCAYT control instance existing
5674_2.patch (1.1 KB) - added by WebSpellChecker.net 7 years ago.
debuging code remove
5674_3.patch (1.2 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Proposed patch

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by WebSpellChecker.net

Attachment: 5674.patch added

add check of SCAYT control instance existing

Changed 7 years ago by WebSpellChecker.net

Attachment: 5674_2.patch added

debuging code remove

comment:1 Changed 7 years ago by Garry Yao

Cc: WebSpellChecker.net added
Keywords: Confirmed Review- added

The error is still there after the patch.

comment:2 Changed 7 years ago by WebSpellChecker.net

the error is different on trunk:

Error: iframe is null
Source File: http://hostname/lib/ckeditor.svn/_source/plugins/wysiwygarea/plugin.js
Line: 718

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: 5674_3.patch added

Proposed patch

comment:3 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Description: modified (diff)
Keywords: Review? added; Review- removed
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

The patch adds the protection and works for me both in trunk and 3.3 branch

comment:4 Changed 7 years ago by WebSpellChecker.net

works for us in trunk

comment:5 Changed 7 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [5502]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy