Opened 9 years ago

Closed 9 years ago

#5714 closed Bug (fixed)

Chrome: Toolbar button label has wrong vertical align

Reported by: Tobiasz Cudnik Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Toolbar Version: 3.2.1
Keywords: Chrome Confirmed Review+ Cc:

Description (last modified by Tobiasz Cudnik)

Toolbar button label has wrong vertical align in Office2003 and V2 skins.

Attaching screenshoot for reference.

Reproduced in Chrome 4 win, 6 linux; using standards mode.

Attachments (3)

2010-05-19-135047_147x95_scrot.png (3.3 KB) - added by Tobiasz Cudnik 9 years ago.
5714.patch (2.5 KB) - added by Garry Yao 9 years ago.
5714_2.patch (2.2 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by Tobiasz Cudnik

comment:1 Changed 9 years ago by Tobiasz Cudnik

Description: modified (diff)

comment:2 Changed 9 years ago by Garry Yao

Keywords: Confirmed added
Version: 3.2.1

Regression from 3.2.1 actually.

comment:3 Changed 9 years ago by Garry Yao

Component: GeneralUI : Toolbar
Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Regression of [5259], proposing here a solution that expires some of the original vertical-align hacks.

Changed 9 years ago by Garry Yao

Attachment: 5714.patch added

comment:4 Changed 9 years ago by Garry Yao

The idea is that by filling the button icon with some text, browsers could properly vertically align them with the text label.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The deletion at line 453 in _source/skins/office2003/toolbar.css brings regression of #4461, easy to check with the toolbar setup provided in comment 1 there.

Changed 9 years ago by Garry Yao

Attachment: 5714_2.patch added

comment:6 Changed 9 years ago by Garry Yao

Keywords: Review? added; Review- removed

It's strange that I can't reproduce it, but anyway, for safety...

comment:7 in reply to:  6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Replying to garry.yao:

It's strange that I can't reproduce it, but anyway, for safety...

Reproduced with IE8 + Quirks, with the toolbar setup provided with ticket:4461:1 comment 1. Anyway, I don't thing this issue has anything to do with this ticket.

comment:8 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5514].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy