Opened 10 years ago

Closed 10 years ago

#5724 closed Bug (fixed)

[Firefox] Maximize one editor instance make other instances uneditable

Reported by: brooks Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Firefox Confirmed Review+ Cc:

Description (last modified by Frederico Caldeira Knabben)

when there are multiple editor instances in one page, maximize one instance and then minimize it.this behavior will make other case uneditable any more.

Attachments (2)

5724.patch (957 bytes) - added by Garry Yao 10 years ago.
5724_2.patch (1010 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed added
Milestone: CKEditor 3.4CKEditor 3.3

This's an unfixed case of #5660.

Changed 10 years ago by Garry Yao

Attachment: 5724.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:3 Changed 10 years ago by Garry Yao

Keywords: Firefox added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Review- added; Review? removed

This code breaks if one of the editors is in source view. It must first check if the relative editor is in wysiwyg mode.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)

Only checking one.document is not enough, because we may be on readonly mode (in the future).

Changed 10 years ago by Garry Yao

Attachment: 5724_2.patch added

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

What about checking editor.mode == 'wysiwyg'? In the future readonly view, editor.mode == 'readonly', probably.

comment:7 in reply to:  6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Replying to garry.yao:

What about checking editor.mode == 'wysiwyg'? In the future readonly view, editor.mode == 'readonly', probably.

Brilliant idea! :P

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5512].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy