Ticket #5725 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

[IE] SCAYT breaks INPUT element selection

Reported by: garry.yao Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE Firefox Cc:

Description

With SCAYT enabled, it's not unable to open context menu on checkbox/radio/textfield/textarea, single click makes the cursor blinking inside those elements now.

Change History

comment:1 Changed 4 years ago by garry.yao

SCAYT must NOT move selection into those elements on click, input editing mode is not allowed in CKEditor, perhaps it's different with other editors in this sense.

comment:2 Changed 4 years ago by SpellChecker.net

SCAYT core updated on spellchecker.net side to avoid this problem.

There still one more problem with form elements: when form element is selected and SCAYT enable/disable item clicked then form element became editable. We are in progress with it.

Just to be sure on ability to edit form elements content: CKEditor allows editing of input elements value if the element clicked when it is already selected (squares in corners indicates selection) with SCAYT disabled - works in IE, in 3.2.1. Is that correct?

comment:3 Changed 4 years ago by garry.yao

CKEditor allows editing of input elements value if the element clicked when it is already selected.

We allow what users could achieve by keyboard and mouse, but we don't interfere the selection around it.

comment:4 Changed 4 years ago by SpellChecker.net

Clear now on form elements edit ability.

We have updated SCAYT core so selected form element does not become editable on SCAYT enable/disable item click.

comment:5 Changed 4 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to fixed

Problem resolved with SCAYT core updates.

comment:6 Changed 4 years ago by garry.yao

  • Status changed from closed to reopened
  • Keywords Firefox added
  • Resolution fixed deleted

This bug is now reproducible on Firefox.

comment:7 Changed 4 years ago by SpellChecker.net

Can be reproduced in 3.2.1 without SCAYT enabled.

comment:8 Changed 4 years ago by garry.yao

I can't reproduce with our 3.2.1 release here, where we don't put cursor inside textfield, but the trunk behavior is different because of SCAYT.

comment:9 Changed 4 years ago by SpellChecker.net

Sorry, but we can’t reproduce situation described in just installed FF.

SCAYT is disabled. We inserted 4 elements: text area, text field, check box, radio box. Then we performed RMB click on each of the elements. Correct context menu is opened for text field, text area and is not opened for check box and radio box. The same behavior is actual for SCAYT enabled. Cursor can’t be inputted in the elements in FF.

Initially we used for testing ckeditor.com/demo

comment:10 Changed 4 years ago by garry.yao

Ok, my fault, I should have clarified that I'm talking about the the left-mouse-click behavior.

comment:11 Changed 4 years ago by SpellChecker.net

Could you please clarify the problem. This ticket states that context menu is unable to open and single click makes the cursor blinking inside elements. In the previous post you said about the left-mouse-click behavior. What behavior you expect on left-mouse-click? Please clarify steps to reproduce with actual and expected results.

comment:12 Changed 4 years ago by garry.yao

  • Cc SpellChecker.net removed

I've verified it a browser issue instead, we'll not bother you anymore on this.

comment:13 Changed 4 years ago by garry.yao

  • Status changed from reopened to closed
  • Resolution set to fixed

#5746 is opened for above issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy