Opened 5 years ago

Closed 5 years ago

#5730 closed Bug (fixed)

Safari: Repeated paste creates issues

Reported by: tobiasz.cudnik Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: Core : Pasting Version: 3.1
Keywords: Webkit Cc:

Description

Repeated paste of simple text hangs the Safari 4.04 on windows.

Reproduce

  1. Start with an empty editor.
  2. Use following simple text:
    foo bar
    
  3. Paste it several times using keyboard by not releasing CTRL+V.

Result

  1. Content similar to:
    <p>
    	&nbsp;</p>
    <p>
    	&nbsp;</p>
    <p>
    	foo barfoo barfoo barfoo barfoo barfoo barfoo barfoo barfoo barfoo barfoo barfoo barfoo barfoo bar</p>
    <br />
    <br />
    <body id="cke_pastebin"></body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    <body id="cke_pastebin">
    	&nbsp;</body>
    

After disabling SCAYT, this can't be reproduced. Looks similar to #5144.

Attachments (1)

5730.patch (583 bytes) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by SpellChecker.net

We couldn't reproduce this using steps provided.

comment:2 Changed 5 years ago by garry.yao

  • Component changed from General to Core : Pasting
  • Keywords Confirmed added
  • Milestone changed from CKEditor 3.3 to CKEditor 3.x
  • Version set to 3.1

Not a SCAYT problem actually, could reproduced by holding down the keys for a while, really an edge case though, we can defer it.

comment:3 Changed 5 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

Changed 5 years ago by garry.yao

comment:4 Changed 5 years ago by garry.yao

  • Milestone set to CKEditor 3.5
  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:5 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.5 to CKEditor 3.4.2

comment:6 Changed 5 years ago by Saare

  • Cc SpellChecker.net removed
  • Keywords Webkit added; Safari removed
  • Status changed from review to review_passed

comment:7 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [5993].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy