Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#5729 closed Bug (fixed)

Safari: h-resize issue in Kama skin

Reported by: Tobiasz Cudnik Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Toolbar Version: SVN (CKEditor) - OLD
Keywords: Safari Confirmed Review- Cc: fckeditor@…

Description (last modified by Tobiasz Cudnik)

In Safari, horizontal resize of Kama skin is broken, not whole editor chrome is resized, eg scrollbar remains still is same position.

Attaching screenshot for reference.

Reproduce

  1. Open resizable editor.
  2. Open link dialogl.
  3. Resize editor's width, reducing it.

Attachments (4)

2010-05-21-100259_646x783_scrot.png (41.5 KB) - added by Tobiasz Cudnik 10 years ago.
5729.patch (912 bytes) - added by Alfonso Martínez de Lizarrondo 10 years ago.
Revert change
5729_2.patch (2.8 KB) - added by Garry Yao 10 years ago.
5729_3.patch (4.4 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (15)

Changed 10 years ago by Tobiasz Cudnik

comment:1 Changed 10 years ago by Tobiasz Cudnik

Keywords: Safari added

comment:2 Changed 10 years ago by Tobiasz Cudnik

Description: modified (diff)

comment:3 Changed 10 years ago by Garry Yao

Component: GeneralUI : Toolbar
Keywords: Confirmed added
Version: SVN (CKEditor)

The inner table width doesn't resize with the container, a webkit layout bug was somehow triggered because of the dialog element (why?).

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

The regression is due to [5379]. It also fails if there's enough content in the body (horizontal) and its resized.

Changed 10 years ago by Alfonso Martínez de Lizarrondo

Attachment: 5729.patch added

Revert change

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

The patch reverts the changeset. It makes resizing slower in Safari, but I think that's better than the current status.

comment:6 Changed 10 years ago by Garry Yao

How about resolve all these two using proxy?

Changed 10 years ago by Garry Yao

Attachment: 5729_2.patch added

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The fix looks like a pretty ugly hack, by using things like .getChild( [1, 0, 0 ] ). But anyway, it could fix the issue at least with the current and default theme.

But, the dragging effect we have now, with the kama skin is quite undesirable (the editor contents disappear), and it's even worst with other skins (the editor completely disappears).

Something better needs to be found, eventually reverting the previous changes, as proposed by Alfonso.

Changed 10 years ago by Garry Yao

Attachment: 5729_3.patch added

comment:8 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Proxy resizing is always the best way to enhance performance and void layout quirks, note that #3601 is an obvious problem for Safari, even more, for slow browsers like IE6.

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Garry, I understand your point here, but the change is far from being good. It's a strong loss of feature, as the editor is not anymore visible when resizing (live preview). Looks like Window 3.1, when windows resizing where done in that same way. But, there is a good reason for it to be different nowadays, so let's making steps backwards here, getting focused on the issue and KISS. Again, the current behavior is "perfect", except with WebKit.

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

I've reverted [5379] with [5516] and this is not anymore an issue.

comment:11 Changed 9 years ago by Danial Pearce

Cc: fckeditor@… added

This fix causes ticket:6212

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy