Opened 10 years ago

Closed 5 years ago

#3601 closed Bug (fixed)

Bad performance at resizing editor in Safari

Reported by: Martin Kou Owned by: Garry Yao
Priority: Normal Milestone:
Component: UI : Toolbar Version: SVN (CKEditor) - OLD
Keywords: Cc: fckeditor@…

Description

To reproduce:

  1. Open replacebyclass.html in Safari/Windows.
  2. Resize the editor.
  3. The resize animation is not smooth.

The bad performance seems to be Windows specific, it seems to be perfectly smooth in Safari/Mac.

Attachments (3)

3601.patch (910 bytes) - added by Garry Yao 9 years ago.
3601_2.patch (4.3 KB) - added by Garry Yao 9 years ago.
3601_3.patch (4.9 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:3 Changed 9 years ago by Garry Yao

Milestone: CKEditor 3.1CKEditor 3.2

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

comment:5 Changed 9 years ago by Garry Yao

Owner: Martin Kou deleted

comment:6 Changed 9 years ago by Garry Yao

We should really consider using proxy, even for other browsers.

Changed 9 years ago by Garry Yao

Attachment: 3601.patch added

comment:7 Changed 9 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

I don't see the described problem in that part of codes on Windows, which slows down the resizing, can somebody confirm it on Mac?

comment:8 Changed 9 years ago by Alfonso Martínez de Lizarrondo

I've applied the patch and I don't see any bad performance or crash as the comments stated, tested with Windows and Mac OS X 10.6.3 with Safari 4.0.5 and Chrome

But due to the crash comment I would prefer for someone else to test and verify that there are no problems by removing that code.

comment:9 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

WFM also, on Mac and Win. It may be related to an old version of Safari. Here is the original comment that introduced that fix: comment:ticket:3564:7.

In the comment I'm stating that the issue affected both Safari 3 and 4. So, even if we're testing only with Safari 4, we should be ok with it (I mean, it was not a Safari 3 only issue).

comment:10 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5379].

comment:11 Changed 9 years ago by Alfonso Martínez de Lizarrondo

That code is needed because now it has triggered #5729

comment:12 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review+ removed
Milestone: CKEditor 3.3CKEditor 3.4
Resolution: fixed
Status: closedreopened

I've reverted [5379] with [5516], because it's bringing a strong issue, as described in #5729.

Changed 9 years ago by Garry Yao

Attachment: 3601_2.patch added

comment:13 Changed 9 years ago by Garry Yao

Component: GeneralUI : Toolbar
Keywords: Review? added; Review- removed

The patch proposes introduce a 'resize_proxy' configuration, which by default set to true for for browsers that have performance/layout problem when doing live-resize.

comment:14 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

As the summary stated the performance problems are only for Safari & Windows. Safari on Mac behaves correctly. Chrome on Windows and Mac also seem to behave quite well for me.

The documentation for config.resize_proxy has been placed before the declaration for config.resize_dir

If the user sets config.resize_proxy=false, it will still be enabled for Safari & IE6.

The IE check will enable the proxy for IE7, although the comment states IE6.

comment:15 Changed 9 years ago by Alfonso Martínez de Lizarrondo

A suggestion: instead of naming this "resize_proxy" that might look strange, what about something like "liveResizePreview" ?

Changed 9 years ago by Garry Yao

Attachment: 3601_3.patch added

comment:16 Changed 9 years ago by Garry Yao

Keywords: Review? added; Review- removed

Decent review, new patch targeting the above points.

comment:17 Changed 9 years ago by Frederico Caldeira Knabben

I'm not reviewing it now. Please note that the configuration must be named "resize_livePreview", not "resize_livepreview".

comment:18 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed removed
Status: reopenedconfirmed

comment:19 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4

comment:20 Changed 9 years ago by Danial Pearce

Cc: fckeditor@… added

comment:21 Changed 7 years ago by Pablo Vanwoerkom

So is this fixed on 3.6.2?

comment:22 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

I cannot reproduce any issue on latest Safari. Works like a charm.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy