Opened 9 years ago

Closed 8 years ago

#5789 closed Bug (duplicate)

Losing leading whitespaces in <pre>

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: Core : Output Data Version: SVN (CKEditor) - OLD
Keywords: Confirmed Cc:

Description (last modified by Garry Yao)

As tells by 'test_pre_leading_whitespaces_toHtml' test, leading spaces are trimmed within pre-formatted text:
run OR view source.

Attachments (2)

5789.patch (1.9 KB) - added by Garry Yao 9 years ago.
5789_2.patch (2.4 KB) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Garry Yao

Description: modified (diff)
Owner: set to Garry Yao
Status: newassigned

Changed 9 years ago by Garry Yao

Attachment: 5789.patch added

comment:2 Changed 9 years ago by Garry Yao

Keywords: Review? added

I have no clue now to see it a regression, instead I see a browser feature here that first leading line-break in <pre> are trimmed, we should be able to compensate this line break so we have the same result in both modes.

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.5

comment:4 Changed 8 years ago by Garry Yao

Description: modified (diff)
Resolution: duplicate
Status: reviewclosed

Duplicate of #5595.

Changed 8 years ago by Garry Yao

Attachment: 5789_2.patch added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy