Opened 9 years ago

Closed 9 years ago

#6077 closed Bug (fixed)

Page Break bug

Reported by: Alex Malikov Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: SVN (CKEditor) - OLD
Keywords: IE Cc: 625alex@…, pavel.jbanov@…

Description

In ticket #5079, page break element was changed from DIV to SPAN. As the result, page breaks don't work anymore, because CSS page-break-after properties only apply to block-level elements.

http://www.w3.org/TR/CSS2/page.html#page-break-props

Change History (4)

comment:1 Changed 9 years ago by Alex Malikov

There is additional side effect due changes for ticket #5709.

Text with line breaks that was created prior to change will not display line breaks in WYSIWYG mode.

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Component: Core : Output DataGeneral
Keywords: IE added; page break plugin removed
Milestone: CKEditor 3.4
Status: newconfirmed

It works well with Firefox, but I can confirm the issue with IE8, unfortunately.

It looks like we need to review the new solution, eventually reverting the changes.

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedassigned

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

I've so reverted [5697] with [5787], so the previous behavior is back.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy