Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#6089 closed New Feature (fixed)

Support for iPad

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: General Version:
Keywords: WebKit Cc: matthewlefflercomputer@…, John Seifarth, mattleff@…

Description

In #5440 we have disabled CKEditor on mobile devices. It looks however that there is a chance that it may work on iOS4.

I do not have a Mac to check it, but it might be worth to investigate it.

Attachments (2)

6089.patch (895 bytes) - added by Garry Yao 7 years ago.
6089_2.patch (1.0 KB) - added by Garry Yao 6 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4.1CKEditor 3.5
Status: newconfirmed

comment:2 Changed 7 years ago by Matthew Leffler

Cc: matthewlefflercomputer@… added

comment:3 Changed 7 years ago by Garry Yao

Milestone: CKEditor 3.5

We have no device at hand to confirm this, defer it.

comment:4 Changed 7 years ago by John Seifarth

Cc: John Seifarth added

I have an iPad with iOS 4.2.1 so I can test immediately.

I tried a drupal installation with CKEditor 3.5, and I only saw plain text in the textarea.

Do I have to enable something special to override your disabling of mobile devices?

comment:5 Changed 7 years ago by Garry Yao

I think we should start testing *good* mobiles, but still haven't seen Apple's claimed the compatibility.

@wawjohn We can start testing it with the above patch applied.

Changed 7 years ago by Garry Yao

Attachment: 6089.patch added

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

The easiest way to check if iOS supports at least the basic features is to check it in a simple div like the one available here: http://alfonsoml.blogspot.com/2010/07/does-android-22-support-contenteditable.html

If you are unable to correctly type, see the caret, select some words... then it would require writting a whole new editor just to deal with the iPad.

With regards to the suggested patch, the problem is that webkit lies and states that contentEditable is supported (even in older versions) as I reported for the Android browser in 2.1 when it didn't support it at all (currently it enables editing but it's useless)

comment:7 Changed 7 years ago by John Seifarth

Thanks alfonsoml, I tested your URL. My iPad, with iOS 4.2.1 (8C148), and Safari doesn't handle it at all, nor does AtomicWeb.

@garry.yao I will test the patch this week sometime.

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: WebKit added
Summary: Support for IpadSupport for iPad

I've opened a ticket for it at WebKit:
https://bugs.webkit.org/show_bug.cgi?id=52583

comment:9 Changed 6 years ago by Ferhat Deliktas

Hi all,

Any progress with this ticket?

Did someone test the patch?

Any ideas when this ticket could be solved?

I had also the issue that the eMail templates are not loaded and it is not possible to type any text, because the textarea is not visible.

Many thanks.

Best Regards,

Ferhat

comment:10 Changed 6 years ago by Alfonso Martínez de Lizarrondo

Have you tested the url that I've provided? Can you see the caret?

If you don't see the caret, what kind of support for the rest of features do you think that we can provide with that limitation?

Only Apple knows when this problem can be fixed. Meanwhile, the new Firefox 4 for mobile provides better support for contentEditable, but of course Apple doesn't allow you to use it. You need an Android tablet for that.

comment:11 in reply to:  10 Changed 6 years ago by Ferhat Deliktas

Replying to alfonsoml:

Have you tested the url that I've provided? Can you see the caret?

If you don't see the caret, what kind of support for the rest of features do you think that we can provide with that limitation?

Only Apple knows when this problem can be fixed. Meanwhile, the new Firefox 4 for mobile provides better support for contentEditable, but of course Apple doesn't allow you to use it. You need an Android tablet for that.

Thank you for your quick answer and sorry for my delay. I could not see the caret on my iPad. I have tried to find a workaround. It seems that the function CKEDITOR.replace() in initCKEditor() does not work properly on the iPad. Is there any workaround to get it work? Please let me know, if you need further information. Many thanks.

comment:12 Changed 6 years ago by Alfonso Martínez de Lizarrondo

If you load that sample url in a normal browser you'll see that there's no CKEditor at all in that page, it's just some static HTML that the iPad isn't able to handle properly.

That's the very basic component of browser editing and Apple doesn't support it correctly in mobile Safari, so you'll have to wait at the very least until iOS 5 (if you are lucky) to see the caret there.

Of course, it would be possible for someone with lots of time and patience to recreate everything from scratch just for the iPads, but I thought that Steve Jobs said that HTML5 was the future and contentEditable is part of HTML5.

comment:13 Changed 6 years ago by Tri

Would it be possible, in the meantime, to fall back to a simple bare textarea? I am using the asp.net control, and prior to 3.6 our iPad users could click on the "view source" button and at least edit the source HTML. Now, with 3.6, the editor control does not render at all (no buttons, no textarea).

comment:14 in reply to:  13 Changed 6 years ago by Frederico Caldeira Knabben

Replying to Tri:

Would it be possible, in the meantime, to fall back to a simple bare textarea? I am using the asp.net control, and prior to 3.6 our iPad users could click on the "view source" button and at least edit the source HTML. Now, with 3.6, the editor control does not render at all (no buttons, no textarea).

The idea is that iPad (and any other incompatible browser) users should not see the editor rendered, but a plain textarea instead. This is the thing to get checked.

Our nightly built demos open a textarea for me. We must check the ASP.NET implementation to see if there is anything wrong there.

comment:15 Changed 6 years ago by Matthew Leffler

Cc: mattleff@… added

Would be good to check iOS5 betas for contentEditable support, if you have a developer account... :)

comment:16 Changed 6 years ago by Kevin Kamel

It's confirmed working in the beta version of tinyMCE:

http://www.gcsdblogs.org/roodhouse/?p=2320

If it works there it can work for CKEditor finally.

Changed 6 years ago by Garry Yao

Attachment: 6089_2.patch added

comment:17 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:18 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.2
Status: reviewreview_passed

Please rename iMobile to iOS when committing.

comment:19 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7100].

comment:20 in reply to:  19 Changed 6 years ago by Matthew Leffler

Replying to garry.yao:

Fixed with [7100].


I think that is [7190] (+[7191]).

Thanks guys – this will be great!

comment:21 Changed 6 years ago by Kevin Kamel

Awesome, this is a long time coming!

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy