Opened 7 years ago

Closed 7 years ago

#6090 closed Bug (fixed)

IE: Textarea with selection inside causes Link dialog issues

Reported by: Tobiasz Cudnik Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version:
Keywords: IE Cc:

Description

In IE, textarea with selection inside, causes Link dialog issues.

Reproduce

  1. Open editor with textarea inside the document.
  2. Click first time to focus textarea.
  3. Click second time close to the border to move selection inside textarea.
  4. Open Link dialog.
  5. Type URL and hit OK.

Result: JS error is thrown.

Attachments (1)

6090.patch (874 bytes) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 6090.patch added

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: newreview

This one has been partially fixed at #5747, but it looks like it was not considering all the possible cases.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4

comment:3 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_passed

Checked on trunk.

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5789].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy