Opened 9 years ago

Closed 9 years ago

#6134 closed Bug (invalid)

[IE Quirks] Table plugin broken / validation impossible

Reported by: Charlie Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.1
Keywords: IE HasPatch Cc:

Description

Under IE Quirks the following coding error comes out:

CKEDITOR.dialog.validate.integer()( value )

should be:

CKEDITOR.dialog.validate.integer( value )

This magically works on every other browser, but in quirks mode it passes a null value and thus makes the table dialog impossible to use.

Patch attached.

NOTE: For some reason, this was impossible to re-produce on the test site and on the exact same code running locally on my computer, yet on our server (same code as local server) the error shows itself. Since this is simply a syntatic fix, compatibility should be improved with no side effects.

Attachments (2)

6134.patch (881 bytes) - added by Charlie 9 years ago.
Fixed syntax
Unbenannt.JPG (92.5 KB) - added by Charlie 9 years ago.
Picture of 'error' and debugging the validation method with one level of step in

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Charlie

Attachment: 6134.patch added

Fixed syntax

comment:1 Changed 9 years ago by Tobiasz Cudnik

Status: newpending

I'm afraid your fix isn't valid, as we're using "factory" functions for validation. The reason for the error you're receiving is execution of this generated function. Removing first execution results in only generating the function, so error disappears.

We would need some detailed error msg or test case, as we can't reproduce it.

comment:2 Changed 9 years ago by Charlie

There is no error message, I simply tracked it down the pipe in IE using the debugger and found that the variable is simply not coming through when the validation function is called (msg is null). Yet it comes through when using the other method.

I guess I don't quite understand why it has to be a "factory" function if it doesn't work all the time. Sorry, I'm not terribly advanced at JS. I'll work on trying to find a test case, but the best I can do for now is a screenshot.

Changed 9 years ago by Charlie

Attachment: Unbenannt.JPG added

Picture of 'error' and debugging the validation method with one level of step in

comment:3 Changed 9 years ago by Charlie

Resolution: invalid
Status: pendingclosed

Ok, I think it has to be something with the specific way I'm calling it or some interaction with other JS on the page. I'm closing this for now, but if you have any ideas on what might cause this type of interaction let me know. Thanks for the help!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy