Opened 7 years ago

Closed 7 years ago

#6179 closed Bug (fixed)

Safari problem with Image Dialog submit

Reported by: Kevin Kamel Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.4.1
Component: General Version: 3.3.2
Keywords: Webkit HasPatch Cc:

Description

Hi,

You can quickly see this problem on the demo page of CKEditor.

Go to CKFinder with Safari, then select or upload an image (doesn't matter). You'll then see the image in the preview pane. Click "ok" - the dialog will not close, and you'll see a little bit of a flicker in the background.

It appears that the window.opener bridge that was working prior to 3.3.2 is now broken.

Affects CKFinder as well as custom image packages that use the window.opener bridge

Bug appears in all versions forward starting with 3.3.2

Attachments (1)

patch (1.6 KB) - added by Kevin Kamel 7 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by Tobiasz Cudnik

Keywords: Webkit added
Status: newpending

Can't reproduce it. Which version of Safari on what OS ?

To clarify you reproduction steps, we're seeing this error using Image dialog ?

comment:2 Changed 7 years ago by Kevin Kamel

Safari version 5

Reproduction of video can be seen here:

http://www.youtube.com/watch?v=0-6-z3WsiMg

This is using a custom window.opener video application

comment:3 Changed 7 years ago by Kevin Kamel

Here is a reproduction using the ckeditor.com website and Safari 5

http://www.youtube.com/watch?v=IUl-if_YFdM

comment:4 Changed 7 years ago by Tobiasz Cudnik

Status: pendingconfirmed

Many thanks for videos.

comment:5 Changed 7 years ago by Kevin Kamel

How about I do one better and tell you exactly how to fix it.

Within file ckeditor/_source/plugins/wysiwygarea/plugin.js

blinkCursor();

else if ( CKEDITOR.env.opera )

doc.getBody().focus();

+ else if ( CKEDITOR.env.webkit ) + { + Selection will get lost after move focus + to document element, save it first. + var sel = editor.getSelection(), + type = sel.getType(), + range = ( type != CKEDITOR.SELECTION_NONE ) && sel.getRanges()[ 0 ]; + doc.getDocumentElement().focus(); + range && range.select(); + } +

editor.focusManager.focus();

});

Someone removed these lines from 3.3.1 -> 3.3.2, for what aims we cannot know because the person didn't comment at all.

Changed 7 years ago by Kevin Kamel

Attachment: patch added

comment:6 Changed 7 years ago by Kevin Kamel

Oh wow, this ticket system doesn't like pasted patches at all.

See attachment for the changes to fix the problem.

Please correct as soon as possible, I don't like hacking my source tree.

comment:7 in reply to:  5 Changed 7 years ago by Frederico Caldeira Knabben

Replying to kamelkev:

Someone removed these lines from 3.3.1 -> 3.3.2, for what aims we cannot know because the person didn't comment at all.

Commenting unexciting code?! Don't be so bad ;) See [5785].

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: HasPatch added

Your patch may bring #6000 back.

comment:9 Changed 7 years ago by Kevin Kamel

It does in fact bring back #6000 - I have this patch currently deployed.

I see #6000 as an extremely minor issue compared to the issue I raise above. The image dialog is a critical component to the editor. Some random warping of the editor is unfortunate, but not exactly a disaster.

Till there is a better patch I'll keep what I've got

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4.1

#6000 is a very important issue, and we need to keep it fixed.

This ticket also deserves attention, so we must bring a solution that satisfies both issues. Your patch is not a solution for it, but I'm sure we'll come with something.

comment:11 Changed 7 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: confirmedassigned

comment:12 Changed 7 years ago by Tobiasz Cudnik

Supposed to be fixed by 6192.patch from #6192.

comment:13 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [5882], for #6192.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy