Opened 10 years ago

Closed 9 years ago

#6225 closed Bug (fixed)

[FF] Can not transform sevaral lines to list with enterMode BR.

Reported by: Sa'ar Zac Elias Owned by: Paweł Horzela
Priority: Normal Milestone: CKEditor 3.4.2
Component: Core : Lists Version: 3.3
Keywords: Firefox Cc:

Description

Open a sample, with enterMode set to br.
Type a few lines of text and click on one of the list icons.
Notice that only the first line is transformed into a list item.
A regression from the 3.3.

Attachments (2)

6225.patch (591 bytes) - added by Paweł Horzela 10 years ago.
Patch
6225_2.patch (1.6 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by Sa'ar Zac Elias

Keywords: Firefox added

comment:2 Changed 10 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: newassigned

comment:3 Changed 10 years ago by Paweł Horzela

This issue was introduced in revision 5694: http://dev.ckeditor.com/changeset/5694

comment:4 Changed 10 years ago by Paweł Horzela

The issue was introduced in #5568 in CKEDITOR.dom.range.setEnd method.

Changed 10 years ago by Paweł Horzela

Attachment: 6225.patch added

Patch

comment:5 Changed 10 years ago by Paweł Horzela

Status: assignedreview

comment:6 Changed 10 years ago by Tobiasz Cudnik

I'm not sure if this patch is correct because TC from #5568 which should prove this can't be executed because of regression #6361. I think we need to wait for #6361 to be fixed.

comment:7 Changed 10 years ago by Tobiasz Cudnik

Although after second thought, those tickets concerns different browsers, so we could also distinguish the logic for each one.

Changed 10 years ago by Garry Yao

Attachment: 6225_2.patch added

comment:8 Changed 10 years ago by Garry Yao

Status: reviewreview_failed

@paho The first part of fix is perfect, I'm adding the second little fix into the iterator now.

@Tobias Let's make the review independent of #6361, I didn't see much relevance.

comment:9 Changed 9 years ago by Paweł Horzela

Status: review_failedreview

comment:10 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:11 Changed 9 years ago by Paweł Horzela

Fixed with [5936]

comment:12 Changed 9 years ago by Paweł Horzela

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy