Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#6286 closed Bug (fixed)

Paste from Word - Numeric bulleted list format issue

Reported by: cbxpounce Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.4
Keywords: Cc: satya_minnekanti@…

Description

Pasting a numbered bullet list from MS Word where a shift+enter was used to put some space between bullets results in HTML that closes the Ordered List tag, placing the BR, then starts a new Ordered list; so, the numbering restarts after the item where the shift+enter was used in the Word Doc.

This in Word:

  1. Item A
  2. Item B


  1. Item C

Becomes this in the Editor:

  1. Item A
  2. Item B



  1. Item C

Resulting HTML between Item B and Item C:

"</ol>
<br />
<br />
<ol>"

Perhaps I am alone in my thought but would have expected to see only the BR tags without closing and opening the Ordered List.

IE 7 and FF 3.6.9

Have tried a number of Word related config settings. Currently using the following, but the same result if not changing any defaults.

config.pasteFromWordNumberedHeadingToList = false;
config.pasteFromWordPromptCleanup = true;
config.pasteFromWordRemoveFontStyles = false;
config.pasteFromWordRemoveStyles = false;

Attachments (1)

Sample 6286.docx (10.8 KB) - added by Krzysztof Studnik 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by Krzysztof Studnik

Keywords: IE Chrome Firefox Opera added
Status: newconfirmed

Confirmed for IE - pasted text is as in reported issue. @Firefox3.6.9: the same text is pasted as:

<p>
	1.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Par1</p>
<p>
	2.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Par2</p>
<p>
	3.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Par3</p>

@Chrome7

<p>
	&nbsp;</p>
<ol>
	<li>
		Par1</li>
	<li>
		Par2</li>
	<li>
		Par3</li>
</ol>

@Opera

<p>
	&nbsp;</p>
<ol>
	<li>
		Par1</li>
	<li>
		Par2</li>
</ol>
<br />
<ol>
	<li>
		Par3</li>
</ol>

comment:2 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

Changed 7 years ago by Krzysztof Studnik

Attachment: Sample 6286.docx added

comment:3 Changed 7 years ago by Wiktor Walc

It looks like will be handled by patch from #7131.

comment:4 Changed 6 years ago by Jakub Ś

Keywords: IE Chrome Firefox Opera removed
Resolution: fixed
Status: confirmedclosed

I have checked the isssue in latest CKEditor 3.6.2.

Now list from the sample is being pasted as one. Closing the ticket.

comment:5 Changed 4 years ago by Frederico Caldeira Knabben

Component: Core : ListsPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy