Opened 7 years ago

Closed 7 years ago

#6413 closed Bug (fixed)

Extra indent in the <pre> tag

Reported by: galeki Owned by:
Priority: Normal Milestone: CKEditor 3.4.2
Component: Core : Output Data Version: 3.1
Keywords: Cc: jude@…

Description

Try insert a <pre> block in a <li> block:

    <li> Code 1
<pre>
abc
def
ghi
</pre>
    </li>

The html source formater auto indent the <pre> tag and the first line of the content of <pre>:

    <li> Code 1
            <pre>
            abc
def
ghi
</pre>
    </li>

So when show in the browser, there is always a extra indent before the first line of the "abc".

Change History (4)

comment:1 Changed 7 years ago by Krzysztof Studnik

Component: GeneralCore : Output Data
Keywords: html format removed
Status: newconfirmed
Version: 3.4.13.1

Occurs since CKEditor 3.1

comment:2 Changed 7 years ago by Garry Yao

Milestone: CKEditor 3.4.2

Will be fixed by #5789.

comment:3 Changed 7 years ago by Jude Allred

Cc: jude@… added

comment:4 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy