Opened 8 years ago

Closed 7 years ago

Last modified 5 years ago

#6449 closed Bug (invalid)

CKEditor 3.4 Paste From Word Issue

Reported by: sourav moy sau Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.4
Keywords: CantFix Cc:

Description

The paste from word is not properly display the content. The styles and fonts are not as it was in word document. The Times New Roman-10 is much smaller than word. I have used word 2007 content and browser IE7 i am attaching three document 1.Word Document which i use

  1. Screen Shot from CKeditor site demo
  2. Screen shot from my application [where in the config the

following line i have added to keep same word structure config.pasteFromWordRemoveFontStyles = false; config.pasteFromWordRemoveStyles = false; but still font and styles mismatch from word content]

Attachments (3)

Sample.docx (23.3 KB) - added by sourav moy sau 8 years ago.
The word content i used to create the screen shot
CkEditorSiteScreenShot.JPG (150.9 KB) - added by sourav moy sau 8 years ago.
Screen shot from CkEditor site demo
LocalSiteScreenShot.JPG (139.5 KB) - added by sourav moy sau 8 years ago.
Screen shot of my local application with config setting to keep structure and font of word

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by sourav moy sau

Attachment: Sample.docx added

The word content i used to create the screen shot

Changed 8 years ago by sourav moy sau

Attachment: CkEditorSiteScreenShot.JPG added

Screen shot from CkEditor site demo

Changed 8 years ago by sourav moy sau

Attachment: LocalSiteScreenShot.JPG added

Screen shot of my local application with config setting to keep structure and font of word

comment:1 Changed 8 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: newassigned

comment:2 Changed 8 years ago by Paweł Horzela

Owner: Paweł Horzela deleted
Status: assignednew

comment:3 Changed 7 years ago by Jakub Ś

Keywords: CantFix added
Resolution: invalid
Status: newclosed

2009 2008 – word passes width=”63” and CKEditor changes it to 63px – wide column == words fit == not a bug.

Line gap is huge – depends how browser sees paragraph tag. This can be styled with CSS - not a bug.

Line gap is huge – the fact that those paragraphs don’t get centered (except Webkit) may look like a bug but again Word gives no alignment information to those browsers - not a bug.

Smaller Times New 10 style – Latest CKEditor recognizes font sizes – not a bug

Border line disappeared – border is visible but not always black - happens in IE6 and IE7 but those browsers don't get any information on border color - not a bug.

Anyway:
In all cases, the editor privileges semantics over formatting, so the end results will never look like the original. CKEditor makes it best to translate the information send from Word through the clipboard and many times it needs to come to an agreement. In those cases we prioritize semantics instead of formatting.

comment:4 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy