Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6451 closed Bug (fixed)

[FF3.6.10] - Multiple CKEditors on Page focus glitch

Reported by: Andrey Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.1
Keywords: Firefox Cc:

Description

I have for instance 5 editors on page. You click on bottom one. Your cursor is in the edit area.

Then you scroll up to the editor num 1 until clicked editor num 5 is no longer visible (it still has cursor in it).

Then you loose focus of the page - click on another window, alt tab to another window, click on desktop, whatever.

Then click back to the page with editors: your window will scroll down to the editor num 5 with cursor in the edit area. This doesn't happen in Chrome or Safari. Happens all the time in FF.

I also managed to glitch Editor to start looping between 3 editors but I will try to reproduce it again...

Change History (3)

comment:1 Changed 9 years ago by Tobiasz Cudnik

Keywords: Firefox added; FF focus multiple editors removed
Status: newpending

Looks like a DUP of #6261. If yes, the fix is available in our nightly build.

comment:2 Changed 9 years ago by Andrey

Resolution: fixed
Status: pendingclosed

Sorry for a dupe, I tested it with the latest version and it wasn't working. This nightly build actually fixed the focus scrolling problem. I haven't tried to replicate infinite loop bug, but that would be a separate ticket. You guys can close it. Thank you. Rock on.

comment:3 Changed 9 years ago by Andrey

Actually cleared cache and it still scrolls up in Firefox with nightly fix :( Sorry folks for multiple posts... Still occurs

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy