Ticket #6509 (closed Bug: wontfix)

Opened 3 years ago

Last modified 22 months ago

Dirty property should probably be set even when source doesn't change

Reported by: dinu Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.1
Keywords: Cc:

Description

If you changes to the document but it ends up unchanged (for example, type a letter then backspace), the editor is not "dirty". This goes against the usual editor implementations, which report being changed. From an interface POV, the data change detection should probably left for the outside application, and the editor should set itself "dirty" if user made any change at some point and it wasn't undone by the undo command. (In which case most editors understand to revert the "changed" flag). Obviously this is a very cosmetic change, just pointing it out for idealistic purposes.

Change History

comment:1 Changed 3 years ago by fredck

  • Status changed from new to pending

The usefulness of the dirty flag is to indicate to the outside application that the data has been changed so, for example, it needs to be saved.

I don't understand the reason for having things dirty if there is nothing really dirty there. Maybe you can clarify this.

comment:2 Changed 3 years ago by dinu

By analogy with the usual implementation of editors; if you were to provide, say, the little tab asterisk that most do to mark something's changed, most don't set/reset it on data change, but on undo stack depth. So my expected behavior after tens of years of editor use is that if I type a letter then erase, the "dirty" flag stays on, and if I type something then "undo" it goes off. There is really no reason, other than everyday habit.

comment:3 Changed 22 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy