Ticket #6542 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 months ago

Safari: space added at the end of style attribute

Reported by: wwalc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Safari Cc:

Description

When aligning a paragraph to the right, an empty space is added at the end of style attribute. Confirmed in Safari 5.0.2 @ Mac.

Steps to reproduce

  • Open replace by class sample
  • Click inside of the first paragraph
  • Press the "Right Justify" button
  • Result:
    <p style="text-align: right; ">
    	This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p> 
    

Related to #6541.

Change History

comment:1 Changed 3 years ago by wwalc

  • Status changed from new to confirmed

comment:2 Changed 3 years ago by wwalc

Same issue happens in Safari 5.0.2 @ Windows.

comment:3 Changed 3 years ago by alfonsoml

The main problem as I explained in #1653 is that the CSS normalization and cleanup is done while adding styles to the content, but to be effective we must do it at reading time.

I hope to work one of these days in #5528 that would fix all these issues at the same time as well as any other change done to the styles by the browsers.

comment:4 Changed 3 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

Could not reproduce this on Safari 7.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy