Opened 8 years ago

Closed 8 years ago

#6543 closed Bug (fixed)

Applying style to selected content deletes the content

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.4.2
Keywords: Safari Mac Cc:

Description

When trying to apply style (for example change the color) to a selection made at the beginning of the content, the content is deleted.

Steps to reproduce

  • Open "Replace by Class Name" sample
  • Select "This" (first word)
  • Click on a "Text Color" button and select green color
  • Result: "This" is deleted.

Confirmed in Safari 5.0.2 @ Mac.

Change History (10)

comment:1 Changed 8 years ago by Wiktor Walc

Actually it doesn't have to be the first word. It also happens, when selecting a word in the middle of the first paragraph.

comment:2 Changed 8 years ago by Krzysztof Studnik

I cannot reproduce this for deleting words under safari 4/mac, selected text is set as green

comment:3 Changed 8 years ago by Garry Yao

WFM on Safari5/Windows.

comment:4 Changed 8 years ago by Wiktor Walc

WFM as well in Safari 5.0.2 @ Windows.

comment:5 Changed 8 years ago by Garry Yao

Milestone: CKEditor 3.4.2

@Wiktor, As we all can't reproduce, can you confirm it regression for 3.4.2?

comment:6 Changed 8 years ago by Wiktor Walc

Yes, it is a regression, caused by [5905].

I think I know why it was hard to reproduce it. I was turning on the error console in Safari once the CKEditor was loaded, to check for JavaScript errors. If the error console is not turned on, the error does not appear.

The main problem is that it didn't happen before, so even if this is a rare use case, we should fix it.

comment:7 in reply to:  6 Changed 8 years ago by Krzysztof Studnik

Status: newconfirmed

Replying to wwalc:

Yes, it is a regression, caused by [5905].

I think I know why it was hard to reproduce it. I was turning on the error console in Safari once the CKEditor was loaded,

With this tip, it can be reproduced @Safari 5 Mac for 3.4.2, and Yes, it cannot be reproduced for CKE 3.4.1, with the same environment set.

comment:8 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.4.2

Since it is a regression caused by #6153, targeting back to 3.4.2.

comment:9 Changed 8 years ago by Garry Yao

Supposed to be fixed by #6545.

comment:10 Changed 8 years ago by Krzysztof Studnik

Resolution: fixed
Status: confirmedclosed

WFM on Safari4 & 5 Mac with 3.4.2 rev 6032 (nightly)

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy