Opened 9 years ago

Closed 8 years ago

#6567 closed Bug (invalid)

Change font size issue

Reported by: Paweł Horzela Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

To reproduce the issue:

  1. Click on 'New Page' on toolbar.
  2. Type couple lines of text.
  3. Select all text by 'Ctrl+A'.
  4. Change font size to 20.
  5. Select (by double clicking) one word.
  6. Change font size to 28.
  7. Select all text by 'Ctrl+A'.
  8. Set font size to 20.

Expected: Font size of all text back to the previous size (as it was before step 4).

Actual: Word with font size 28 didn't change it's font size. All other text back to the previous size.

Change History (5)

comment:1 Changed 9 years ago by Paweł Horzela

Looks very similar to #5931.

comment:2 Changed 9 years ago by Tobiasz Cudnik

I don't think that expected effect is a valid one, why a text with the font size 28 should go to size-less after applying font size 28, what's the relation here ?

What should happen instead IMO, is that text with the font size 28 goes to the size 20, while a text with the size 20 becomes size-less.

This is not a DUP of #5931.

comment:3 Changed 9 years ago by Tobiasz Cudnik

There's an error in first paragraph of my comment, it should be "go to size-less after applying the font size 20".

comment:4 Changed 9 years ago by Garry Yao

Agree with Tobias, as we're talking of removing a particular style (20px) but not applying, so it make sense that different inner styles (28px) remains.

comment:5 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I agree with @garry.yao and @tobiasz.cudnik.

Font size for the whole selection is 20px. You know it because it is marked in dropdown list. When you select 20px from the dropdown list it means that you want to remove this particular font size and that's what is happening - all text with size 20px gets back to it's normal size. If on the other hand, you chose 10px, all the text including the part with size 28px would be changed to 10px.

I see no error here. closing the ticket as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy