Opened 12 years ago

Closed 11 years ago

#660 closed Bug (worksforme)

Problems with smartNavigation=True

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: SVN (FCKeditor) - Retired
Keywords: SF WorksForMe Cc: jakedotnet@…

Description

FCKeditor's ASP.NET component failes to load when you set FCKeditor control's Visible property to FALSE in aspx codebehind code and then set it back tu TRUE If aspx page's smartNavigation is enabled.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1199768&group_id=75348&atid=543653

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to anonymous

I have this problem. I'm using Visual Studio 2005. It messes up, says "Unspecified Error" and highlights the line:

this.Window=D.contentWindow;

in:

\FCKeditor\editor\js\fckeditorcode_ie.js


Moved from SF. Original poster: jakedotnet

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralServer : ASP.Net

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: WorksForMe added
Resolution: worksforme
Status: newclosed
Version: SVN

Hi!

I've done some test and I was unable to reproduce your bug with this code

<%@ Register Assembly="FredCK.FCKeditorV2" Namespace="FredCK.FCKeditorV2" TagPrefix="FCKeditorV2" %>
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs"  Inherits="WebApplication2._Default" SmartNavigation="true"%>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title>ASP.NET Test Page</title>
</head>
<body>
    <form id="form1" runat="server">
    <FCKeditorV2:FCKeditor ID="FCKeditor1" runat="server" Visible="true"></FCKeditorV2:FCKeditor>
    <div>
    
    </div>
    </form>
</body>
</html>

I've set the Visible parameter back and forth from true to false, and run the page every time and no bug occurred.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy