Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6621 closed Bug (fixed)

Webkit: Cannot apply a text color because of an input element

Reported by: Tobiasz Cudnik Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.4.2
Keywords: Webkit Cc:

Description (last modified by Tobiasz Cudnik)

In Chrome, we cannot apply a text color because of an input element.

  1. Use the following content:
    <p>
    	foo</p>
    <p>
    	<input type="radio" />bar</p>
    
    1. Select all.
    2. Set a text color.

Result: The color is applied only to the first paragraph ("foo").

This is an regression against 3.4.1.

Attachments (2)

6621.patch (997 bytes) - added by Sa'ar Zac Elias 7 years ago.
6621_2.patch (2.5 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by Tobiasz Cudnik

Status: newconfirmed

Blockquote is also affected.

comment:2 Changed 7 years ago by Tobiasz Cudnik

Description: modified (diff)

comment:3 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.4.2
Version: 3.4.2 (SVN - trunk)

Regression

comment:4 Changed 7 years ago by Wiktor Walc

Caused by [5873] (#6282).

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

I think wwalc wanted to point to [5973] instead.

comment:6 Changed 7 years ago by Tobiasz Cudnik

The important fact: the select element doesn't trigger such behavior.

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

comment:8 Changed 7 years ago by Garry Yao

What I'm seeing here: Webkit divides the range into two, separated by the radio, while it selection system has a bug that prevent from making a text selection that start after a radio later.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6621.patch added

comment:9 Changed 7 years ago by Sa'ar Zac Elias

Status: assignedreview

Reverted [5973], and made the bookmarks serializable. That resolves all 3 issues (this one, #6282, #6004).

comment:10 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

comment:11 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6035].

comment:12 Changed 7 years ago by Garry Yao

Actually we accepted 6221.patch as an urgent fix, while a cleaner fixes has to be delivered only for this particular case, but not bringing back [5744], which introduces complexities to the codes.

Providing here a second patch to be considered later.

Changed 7 years ago by Garry Yao

Attachment: 6621_2.patch added
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy