Ticket #6639 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 months ago

Pasting from Word a nested list with an empty paragraph doesn't work

Reported by: wwalc Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.1
Component: Plugin : Paste from Word Version: 3.1
Keywords: Cc:

Description

When there is a list with another nested list, that contains an empty paragraph created with Shift+Enter, pasting from Word generates an invalid result.

Word document:

 1.	One
    a.	Nested list 1
    b.	Nested list 2

    c.	Nested list 3
    d.	Nested list 4
 2.	Two
 3.	Three
 4.	Four

result after pasting from Word into CKEditor:

 1.One
    1.Nested list 1
    2.Nested list 2




 1.Nested list 3
 2.Nested list 4
 3.Two
 4.Three
 5.Four 

Attachments

nested_list_with_empty_lines.docx (13.6 KB) - added by wwalc 3 years ago.
6639.patch (623 bytes) - added by tobiasz.cudnik 3 years ago.
6639_2.patch (1.4 KB) - added by garry.yao 3 years ago.
6639_3.patch (1.0 KB) - added by garry.yao 3 years ago.

Change History

Changed 3 years ago by wwalc

comment:1 Changed 3 years ago by wwalc

  • Milestone changed from CKEditor 3.6 to CKEditor 3.5.1

comment:2 Changed 3 years ago by garry.yao

  • Status changed from new to confirmed
  • Version set to 3.1

To not make the TC complicated, the bug is just about pasting the nested list, we must understand how line-break (SHIFT-ENTER) affects our list resolution.

comment:3 Changed 3 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

Changed 3 years ago by tobiasz.cudnik

comment:4 Changed 3 years ago by tobiasz.cudnik

  • Status changed from assigned to review

The solution is really simple, although finding the reason weren't. I think there can be more places suffering from lack of the XML namespace support in our codebase...

Changed 3 years ago by garry.yao

comment:5 Changed 3 years ago by garry.yao

  • Status changed from review to review_failed

I don't see the patch fix the problem, also, we need to keep namespaced elements intact with "cke" as prefix, see flash plugin.

comment:6 Changed 3 years ago by garry.yao

  • Owner changed from tobiasz.cudnik to garry.yao
  • Status changed from review_failed to review

comment:7 Changed 3 years ago by Saare

  • Status changed from review to review_failed

I'm not sure if we should mix up our own things in the dtd.

comment:8 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

Dollar prefixed dtd entries are all "none-generated" definitions that were added by us as additional semantics.

comment:9 Changed 3 years ago by Saare

  • Status changed from review to review_failed

We can inline the tag name for that, no need for another dtd entry.

Changed 3 years ago by garry.yao

comment:10 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

comment:11 Changed 3 years ago by Saare

  • Status changed from review to review_passed

comment:12 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6317].

comment:13 Changed 2 months ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy