Ticket #6782 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

IE8 bug: Bookmark span tag doesn't get removed on context menu paste

Reported by: joolee Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.4.2
Keywords: Cc:

Description

To recreate:

  1. Type text into CKEditor.
  2. Copy text.
  3. Right-click at position after the text and select paste.
  4. Go to Source mode.

You'll see <span style="display: none">&nbsp;</span> from CKEditor bookmark.

Because of the above behavior, when you paste twice in a row, the second paste is pasted inside the span, which causes it to be hidden.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by tobiasz.cudnik

  • Status changed from new to pending

I can't reproduce it, does this happen to you on the demo site?

comment:2 in reply to: ↑ 1 Changed 3 years ago by joolee

Replying to tobiasz.cudnik:

I can't reproduce it, does this happen to you on the demo site?

Yes, this happens on the demo site. Try these steps:

  1. Copy the last paragraph that starts with "The tale makes the..."
  2. Place your cursor at the end of the same paragraph.
  3. Right-click on that place on the cursor and select Paste.
  4. Click "Allow access" button.
  5. The paragraph should be now copied and the cursor placed at the end of the paragraph.
  6. Without changing the cursor position, right-click on that place on the cursor and select paste again.

You'll not see the second paste. If you go to the source mode, you'll see what happened. Here's the source:

<p>

<span style="display: none">The tale makes the clearest contrast between the safe world of the village and the dangers of the <a href="http://en.wikipedia.org/wiki/Enchanted_forest" title="Enchanted forest">forest</a>, conventional antitheses that are essentially medieval, though no written versions are as old as that.<span style="display: none">&nbsp;</span></span></p>

<p>

<span style="display: none">&nbsp;</span></p>

comment:3 Changed 3 years ago by 625alex

This is a duplicate of #7608.

comment:4 Changed 2 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

This is no longer reproducible in latest stable CKEditor 3.6.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy