Opened 9 years ago

Closed 8 years ago

#6783 closed Bug (duplicate)

Large amount of text insert as divs rather then paragraphs in webkit

Reported by: dstol Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.1
Keywords: Webkit Cc:

Description

OS X 10.6.4

Safari 5.0 (6533.16)

CKEditor, latest stable as well as latest nightly

Enter mode is paragraphs

Steps to reproduce: Grab large chunk of plain text lorem ipsum

Paste into CKEditor, used demo at http://ckeditor.com/demo after

emptying contents

View source tab

<p>
	&nbsp;</p>
<div>
	Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc sagittis mattis venenatis....</div>
<div>
	&nbsp;</div>
<div>

In FF 3.6.12, using the same steps above

<p>
	Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc sagittis mattis venenatis....<br />
	<br />

Attachments (1)

lorem.txt (4.4 KB) - added by dstol 9 years ago.
5 Paragraphs of lorem ipsum

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Garry Yao

Status: newpending

Grab large chunk of plain text lorem ipsum

Please provide precisely the source content and from which application it's copied, those make a difference.

Changed 9 years ago by dstol

Attachment: lorem.txt added

5 Paragraphs of lorem ipsum

comment:2 Changed 9 years ago by dstol

If it's helpful, I can post a screen cast.

comment:3 Changed 9 years ago by dstol

Screen cast as promised: http://screenr.com/ipt

comment:4 Changed 9 years ago by dstol

Summary: Large amount of text insert as divs rather then paragraphs in safariLarge amount of text insert as divs rather then paragraphs in webkit

Just duplicated this in chrome 9.0.597.84, so it seems to be webkit related.

comment:5 Changed 9 years ago by Garry Yao

Keywords: Webkit added
Status: pendingconfirmed
Version: 3.4.23.1

It's much about a browser favorite, we recommend the "paste as plain text" button to reach a consistent/rational result (multiple P) when pasting just plain text.

We'd still investigate if it's possible to optimize the result (of a normal paste) as end users were used to do just Ctrl-V in all cases.

comment:6 Changed 8 years ago by Garry Yao

Resolution: duplicate
Status: confirmedclosed

DUP of #7146

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy