Opened 8 years ago

Closed 7 years ago

#6784 closed Bug (fixed)

IE content deletion bug when adjusting indentation levels of bulleted or numbered lists

Reported by: Jude Allred Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE8 IE9 Cc:

Description

Repro steps:

  1. Use IE8 or IE9
  1. Go to http://ckeditor.com/demo
  1. click New Article
  1. Click to create either a bulleted or numbered list
  1. type 'cat'
  1. press enter
  1. click Increase Indent
  1. type 'mouse'
  1. press enter 3 times so that the cursor escapes the list
  1. press backspace to place the cursor at the end of 'mouse'
  1. press enter 3 more times

Expected: Cursor has again escaped the list, as in step 9

actual: 'mouse' has been deleted.

Note that this bug will actually delete the entire inner tier of the list, and can also be invoked via some other (more difficult to reproduce) circumstances.

Attachments (1)

deletion.avi (1.1 MB) - added by Jude Allred 8 years ago.
Video of the repro against ckeditor.com/demo

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Jude Allred

Attachment: deletion.avi added

Video of the repro against ckeditor.com/demo

comment:1 Changed 8 years ago by Krzysztof Studnik

Keywords: IE8 added
Status: newconfirmed
Version: 3.0

Confirmed since CKE 3.0 under IE8. Under Chrome works OK.

comment:2 Changed 7 years ago by Jude Allred

This appears to have been fixed. Yay!

comment:3 Changed 7 years ago by Jakub Ś

Keywords: IE9 added
Resolution: fixed
Status: confirmedclosed

Fixed with CKEditor 3.5.3

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy