Opened 8 years ago

Closed 5 years ago

#6824 closed Bug (invalid)

Alignment is not observed after paragraph format has been applied

Reported by: James Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IBM Discussion Cc: Damian, joek, Satya Minnekanti

Description

Steps to reproduce the defect:

  1. Open the Ajax sample.
  2. Click on Align Right (or Align Centre).
  3. Select Heading 1 from the paragraph format drop down list.
  4. Type some text & press Enter.

Expected: The cursor stays Right Aligned (or Centre Aligned).

Actual: The cursor becomes Left Aligned.

Change History (3)

comment:1 Changed 8 years ago by Krzysztof Studnik

Keywords: Discussion added
Status: newpending

Behaviour is confirmed for CKEditor, but the same behaviour is in MS Word 2007.

  • Set Heading 1 and allign to right
  • type some text and press enter
  • cursor is aligned to left (formating is set to "Normal")

I think, it is not a bug.

comment:2 Changed 8 years ago by Krzysztof Studnik

Version: 3.4.3 (SVN - trunk)3.0

comment:3 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

Google Docs and MS Word drop alignment when they change format on enter. So CKEditor behaves like other editors and that's good.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy