Opened 9 years ago

Closed 6 years ago

#7119 closed Bug (fixed)

Cursor skipping additional character after contentEditable="false"

Reported by: Dinu Owned by:
Priority: Normal Milestone:
Component: Core : Read-only Version: 3.3
Keywords: IBM Cc: satya_minnekanti@…

Description

Assumption:

  • arrows, backspace and del should work around contenteditable spans
  • no wrong refactoring should be due to CK


Test:
1) Set contents to

ABCD<span contenteditable="false">EFGH</span>IJKL

Problems:
Firefox: arrows move caret one character off, effectively skipping one extra character; backspace doesn't work on span, del works but removes one extra character

2) Set contents to

ABCD<span contenteditable="false">EF<span contenteditable="true">12</span>GH</span>IJKL

Problems:
Webkit: Placing caret after F or H and hit backspace, or before E or G and press Del, strange refactoring occurs.
IE: cursor can't enter or leave inner span using arrows; probably browser related
Firefox: ditto

(Unrelated yet related): API demo seems broken in Opera, can't set editor contents. Will try later.

I'm not sure if I needed to create separate tickets, seems that since the test case is this specific functionality (have keyboard operations work on contenteditable areas), should all go in one place.

Change History (4)

comment:1 Changed 9 years ago by Krzysztof Studnik

Component: GeneralCore : Read-only
Status: newconfirmed
Summary: New oddities concerning contenteditable in 3.5.1Cursor skipping additional character after contentEditable="false"
Version: 3.5.13.3

Confirmed. Second test case, under IE and Firefox are related to first, where cursor skips one character. Because it is a bug which also occurs in previous versions of CKEditor, I changed Summary of this ticket.

comment:2 Changed 9 years ago by Dinu

The webkit refactoring doesn't seem connected to the cursor skipping peculiarities...

comment:3 Changed 9 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Thanks to #9764 most of these issues (if not all) were fixed in CKEditor. Although, there's no support for nested inline editables (#10974).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy