Opened 8 years ago

Closed 6 years ago

#7170 closed Bug (fixed)

[IE] incorrect cursor position after enter in pre blocks

Reported by: Karen Ananiev Owned by: Garry Yao
Priority: Normal Milestone:
Component: Core : Selection Version: 3.0
Keywords: IE Cc:

Description

Open sample, create preformatted block, type any text and press enter (note that cursor blinks at the start of current line. the new typed text will appear on the new line though). Create a few more lines with text. Click opposite one of the lines to put cursor to the end of it and press enter. In some cases the new line will be created but cursor will appear at the start of the next line.

Attachments (1)

7170.patch (2.2 KB) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by Garry Yao

Component: GeneralCore : Selection
Keywords: IE added
Status: newconfirmed
Version: 3.0

An unfixed case of #3949.

comment:2 Changed 8 years ago by Garry Yao

Observed another quirks of IE selection in <pre>:

  1. Load the following content:
    <pre>
    line one
    the second line
    </pre>
    
  2. Select word "one" and apply bold style;
  • Actual Result: The style been applied with one character shifted off.

Changed 8 years ago by Garry Yao

Attachment: 7170.patch added

comment:3 Changed 8 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

The patch (created on 3.6 branch) propose of using <br> consistently in good browsers (preserving text breaks only for IE6&7)inside pre-formatted block which has the following benefits:

  1. Reduce selection bug introduced by using text breaks;
  2. Easier range position management after line break insertion.

comment:4 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: reviewclosed

I can't reproduce original TC in IE in latest CKEditor 4.1.2.

TC reported ny garry.yao has been described here: #10554.

I'm closing this issue as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy