Opened 12 years ago

Closed 7 years ago

#762 closed Bug (wontfix)

Outside Flash goes over the maximized editor

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: SF Firefox Cc: Frederico Caldeira Knabben

Description

Hi,

When you click on the Maximize the editor size button and you have flash files (swf) loaded in your page, the flash files are showed over the text area of FCKeditor.

Regards, André.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1529145&group_id=75348&atid=543653

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to anonymous

He meant, having Flash in the page where the editor is placed, outside the editor.

Much probably the object/embed z-index is higher than the rest of the page.


Moved from SF. Original poster: fredck

comment:2 Changed 12 years ago by Martin Kou

Keywords: Confirmed Firefox added
Version: SVN

It's ok in IE, but the Flash object always stays on top in Firefox.

It seems to be a bug in the Flash plugin though, since defining a lower z-index for the <embed> node in Firebug does nothing to help the situation, and maximizing FCKeditor somehow causes the Flash object to reload itself.

Perhaps the only real solution is to seek out all <embed> nodes in the outer document and hide them when FCKeditor goes to fit window mode.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy