Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8081 closed Bug (duplicate)

Safari on Mac : Cursor goes out of editor body when auto grow kicks in

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect;

  1. Open a CK Editor sample with auto grow plug in loaded.
  1. press enter 5 times to create 5 empty paragraph
  1. press enter for the 6th time.

Expected Result: Editor body size should increase automatically with out any scrollbars no matter how many paragraphs we created in editor body.

Actual Result: we will see a scrollbar for few seconds and cursor goes out of editor body

  1. keep cursor in editor body and press backspace to delete the last empty paragraph.

Expected Result: Empty paragraph is deleted & cursor goes to previous empty paragraph

Actual Result: Empty paragraph is deleted and cursor goes out of editor body.

This issue was reported in #6969 which was closed as fixed but it came back after reverting the fix for #7173.

Change History (2)

comment:1 Changed 8 years ago by Wiktor Walc

Resolution: duplicate
Status: newclosed
Version: 3.6.1 (SVN - trunk)3.4

Let's trace this issue in #6969. Due to the various issues discovered after committing #7173 we've decided to revert it and work on a better patch.

@satya sorry for the typo, I have corrected the link to the right ticket: #6969.

Last edited 8 years ago by Wiktor Walc (previous) (diff)

comment:2 Changed 8 years ago by Satya Minnekanti

It should be tacked in #6969 instead of #6966 which is a diff issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy