Opened 10 years ago

Closed 10 years ago

#8087 closed Bug (fixed)

RTL: Indenting list adds extra dir attributes to list items.

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: Core : Lists Version: 3.6.1
Keywords: Cc: satya_minnekanti@…

Description

Caused by [6928].

  1. Start with
    <ul dir="rtl">
    	<li>
    		one</li>
    	<li>
    		two</li>
    	<li>
    		three</li>
    	<li>
    		four</li>
    </ul>
    
  2. Select two list items in the middle ("two" and "three").
  3. Press "Increase Indent"
  4. Result:
    <ul dir="rtl">
    	<li>
    		one
    		<ul>
    			<li dir="rtl">
    				two</li>
    			<li dir="rtl">
    				three</li>
    		</ul>
    	</li>
    	<li>
    		four</li>
    </ul>
    

Previously the result was:

<ul dir="rtl">
	<li>
		one
		<ul>
			<li>
				two</li>
			<li>
				three</li>
		</ul>
	</li>
	<li>
		four</li>
</ul>

Attachments (3)

8087.patch (2.3 KB) - added by Garry Yao 10 years ago.
8087_2.patch (2.9 KB) - added by Garry Yao 10 years ago.
8087_3.patch (2.7 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

At least #6861, #8042, #8053 must be re-checked.

Changed 10 years ago by Garry Yao

Attachment: 8087.patch added

comment:4 Changed 10 years ago by Garry Yao

comment:5 Changed 10 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:6 Changed 10 years ago by Wiktor Walc

Milestone: CKEditor 3.6.1CKEditor 3.6.2

Unless anything more serious will be found while working with lists, we can correct it in the next release.

The text direction is correct, so let's work on it straight after the release to keep the resulting HTML code as clean as possible.

Changed 10 years ago by Garry Yao

Attachment: 8087_2.patch added

comment:7 Changed 10 years ago by Garry Yao

Looks like wiser to just keep element::getDirection simple.

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: NeedsTest added

comment:9 Changed 10 years ago by Garry Yao

Last edited 10 years ago by Frederico Caldeira Knabben (previous) (diff)

Changed 10 years ago by Garry Yao

Attachment: 8087_3.patch added

comment:10 Changed 10 years ago by Garry Yao

Keywords: NeedsTest removed

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:12 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7219].

Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy