Opened 8 years ago

Closed 8 years ago

#8269 closed Bug (duplicate)

Opera : Copying and pasting tables not working properly (CORE-41467)

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0.2
Keywords: IBM Opera Cc: Damian, James Cunningham, Hallvord R. M. Steen (Opera Software)

Description

To reproduce the defect:

  1. Open any CK Editor sample and insert a table with default values(3 rows & 2 columns)
  1. Enter content in all table cells, keep cursor inside a table cell & select table tag in elements path bar.
  1. See that entire table is selected.
  1. Copy the table using Ctrl + C, keep cursor after the table and paste using Ctrl + V.

Expected Result: Table should be pasted properly

Actual Result: Table not pasted properly with out borders. we can't see Delete Table/Table Properties options in context menu and also we can't open Cell sub menu.

When we look at html source it shows it's missing the table tag for the pasted table

when we go back to Rich Text all the content in pasted table cells are merged in to one simple paragraph.

Change History (5)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: Opera added
Status: newconfirmed
Version: 3.0.2

Reproducible from CKE 3.0.2

comment:2 Changed 8 years ago by Jakub Ś

This issue may have something in common with #7846

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Cc: Hallvord R. M. Steen (Opera Software) added

comment:4 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Summary: Opera : Copying and pasting tables not working properlyOpera : Copying and pasting tables not working properly (CORE-41467)

reported as CORE-41467 on Opera's side. I would certainly close this as dup of #7846.

comment:5 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

DUP of #7846

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy