Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8270 closed Bug (invalid)

Inserting links sometimes doesn't work

Reported by: Jason Purdy Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: Cc:

Description

This is similar to issue #6730, but I'm experiencing it with a newer version than that issue was closed on.

In the attached screenshot, I double-clicked on the word Officia and clicked the link button, pasted a URL and hit Ok and the result was not as intended, as you can see. The URL is placed at the beginning of the paragraph vs. linking the word Officia to the URL.

For what it's worth, this is the stock CKEditor inside the Movable Type blogging platform.

Attachments (1)

ckeditor.png (184.5 KB) - added by Jason Purdy 8 years ago.
screenshot of the problem

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Jason Purdy

Attachment: ckeditor.png added

screenshot of the problem

comment:1 Changed 8 years ago by Jakub Ś

Status: newpending

Could you tell me what browser you are using (name and version) and what kind of CKEditor we are talking about - pure JS or CKEditor integration for Java/PHP/.NET ...?

Also does this issue is reproducible in clean version of CKEditor or only inside your platform? This would indicate configuration settings not CKEditor error.

Have you tried to upgrade to CKEditor 3.6.1? Maybe this issue has already been solved.

Waiting for your feedback.

comment:2 Changed 8 years ago by Jason Purdy

Browser: Google Chrome 15.0.854.0 dev Pure JS

I haven't tried a clean version of CKEditor, nor have I tried upgrading to 3.6.1.

Thanks!

comment:3 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Chrome 15.0.854.0 dev is as its name states developer version which can have many bugs. CKSource does not support such versions only latest stable. In this case latest stable Chrome 13 and no such problem occurs there.

I’m closing this ticket as invalid.

comment:4 Changed 8 years ago by Jason Purdy

I got this report from a user that uses a different browser ... let me find out what he uses, though it seems you're predisposed to not address this issue.

comment:5 Changed 8 years ago by Jakub Ś

If the issue had occurred in any stable release than this issue would have been treated as valid. If we weren’t interested in fixing bugs we wouldn’t open trac for it in first place.

If you are able to provide me with browser number which is not developer version than I will reopen this issue and will try to reproduce it.

Any step by step scenarios or sample files that help to reproduce the issue are also welcome.

comment:6 Changed 8 years ago by Anna Tomanek

Purdy,

In general we are not "predisposed" to not address any issues that are reported here since we appreciate that the users are spending their valuable time to let us know that something might be wrong with our product.

For more information about our support model please refer to a recent blog post published here: http://cksource.com/blog/CKSource_Graded_Browser_Support. The support matrix is also available in the User's Guide: http://docs.cksource.com/CKEditor_3.x/Users_Guide/Compatibility.

If this issue occurs in any of the browsers listed in the linked articles, we will happily investigate it.

comment:7 Changed 8 years ago by Jason Purdy

Ok, cool - that's good to know ... I guess I was reading too much into your response. I'm sorry about that.

I heard back from my user and he's using Safari 5.0.6.

comment:8 Changed 8 years ago by Jason Purdy

Here's some more information from my user:

For me, the first issue seems to happen every time except the first time I try to put in a link. Usually the first link is successful, then every one following goes into the text on a first attempt, and into the intended hyperlink on the second attempt.

comment:9 Changed 8 years ago by Jason Purdy

Actually, now that I'm trying to reproduce this and dig deeper, I see that this is NOT a CKEditor issue, but an issue with MovableType's built-in editor. I thought CKEditor was enabled, but it was not, so this is an invalid issue for CKEditor.

My apologies for this whole mess. :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy