Opened 8 years ago

Closed 6 years ago

#8274 closed New Feature (fixed)

editor API to query command state

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: v4 Cc:

Description

Command state is now updated by the "selectionchange" event only, while it's more of an UI event (which have latency), we need an command API to query the command state explicitly and optionally update it.

Change History (2)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Seems to be fixed. One can force selection change check using http://docs.ckeditor.com/#!/api/CKEDITOR.editor-method-forceNextSelectionCheck. Context sensitive commands are always updated accordingly. And if any command needs to be updated more often, one can force that calling command.refresh().

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy