Opened 6 years ago

Closed 6 years ago

#8364 closed Bug (invalid)

Error when opening Link-dialog in IE 9

Reported by: Henrik Helmø Larsen Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.6.1
Keywords: Cc:

Description

I am currently using version CKEditor 3.6.1 and have found a bug in the plugin.js file of the dialog folder.

I have modified the link dialog - (code added at the end). The dialog displays without problems in both FF and Chrome. In IE 9.0.8112 an error is displayed:

SCRIPT5007: Unable to get value of the property 'align': object is null or undefined plugin.js, line 2539 character 7

The problem is the following line:

if ( CKEDITOR.env.ie && CKEDITOR.env.quirks && children[ i ].align )

in the plugin.js in the dialog folder. The children[ i ] is null or undefined. A quick solution is to add a check for children[ i ]:

if ( CKEDITOR.env.ie && CKEDITOR.env.quirks && children[ i ] && children[ i ].align )

My code:
As it is inside a vbox the bug occurs (I believe it is when the radio buttons are defined) I have copied the part of my code where i define the UI of the dialog (and tried to remove unrelevant things - but let me know if you need more code...):

var infoTab = dialogDefinition.getContents( 'info' );
infoTab.add( {
  type : 'hbox',
  padding : 1,
  widths : ['100px', '100%'],
  id: 'outer',
  align: 'center',
  children : [
    // Insert Link to:
    {
       type : 'vbox',
       padding : 1,
       width : '100px',
       id: 'LinkType',
       align: 'left',
       children : [
         {
           type : 'radio',
           id : 'radioLink',
           label : 'Insert link to:',
           labelLayout: 'vertical',
           items : radioButtons,
           setup : function( data ) {
             debug("Setup...");
             //a lot of setup code removed... 
           },
           onChange : function( api ) {
              debug("onChange...");
              //code removed
           }
         }
       ]
     },
     {
       type : 'vbox',
       padding : 1,
       width : '100%',
       id: 'LinkCont',
       align: 'right',
       children : [
         {
           type : 'vbox',
           padding : '0px 0px 20px 0px',
           id: 'innerLinkList',
           align: 'right',
           children : [
             {
               type : 'select',
               id : 'link',
               items : [],
               size : 11,
               multiple : true
             }
           ]
         },
         {
           type : 'text',
           id : 'linkurl',
           label : 'Address (URL):',
           'default' : '',
           labelLayout : 'horizontal',
           validate : function(api) {
             //Code removed
           }
         },
         {
           type : 'text',
           id : 'linktext',
           label : 'Displayed Text:',
           'default' : '',
           labelLayout : 'horizontal',
           validate : function() {
             //Code removed
           }
         }
       ]
     }
  ]
});

// Remove the "Link Type" combo and the "Browser
// Server" button from the "info" tab.
infoTab.remove( 'linkType' );
infoTab.remove( 'browse' );
infoTab.remove( 'protocol' );
infoTab.remove( 'url' );

// Remove the "Target" tab from the "Link" dialog.
dialogDefinition.removeContents( 'target' );

//Remove the "Advanced" tab from the "Link" dialog
dialogDefinition.removeContents( 'advanced' );

Attachments (1)

IE_problem.zip (1.2 MB) - added by Henrik Helmø Larsen 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by Henrik Helmø Larsen

Summary: Error when opening Link-dialogError when opening Link-dialog in IE 9

comment:2 Changed 6 years ago by Jakub Ś

Status: newpending

We surely do.

It would be nice if you could provide a sample reduced and working TC showing the problem so that we could get the whole picture.

comment:3 Changed 6 years ago by Jakub Ś

@Helmø any updates on this reduced TC?

Changed 6 years ago by Henrik Helmø Larsen

Attachment: IE_problem.zip added

comment:4 Changed 6 years ago by Henrik Helmø Larsen

Sorry for not getting back to you - but I have had big problems logging in to your site. The system would not resend a password to my old login (Helmø) - which i have forgotten :-( - so therefore I have created this new one...!
By the way - how do I get my old account back (Helmø) - I have been waiting for days for the email - but it doesn't come?!?

I have used a long time to make a reduced and working version - I don't want to use more time. I have found out that the problem I have reported is caused because I have made a change in the CKEditor (see case #5094). When using the vBox layout for the radio button - the error occurs. This should be taken into account when implementing #5094. The problem is only present in IE9 when CKEDITOR.env.quirks is set. (In the attachment above I have included a version of ckeditor where the vBox layout is possible - it is a copy of version 3.6.1 with only this modification, and some language files missing in order for the size to be below 1.5MB)

comment:5 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Ok I'm closing your issue as it concerns feature which was not implemented yet. User custom modification is not CKEditor bug.

Thank you for linking this ticket to #5904. Your note might be useful when this feature will be implemented.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy