Opened 7 years ago

Last modified 7 years ago

#8365 confirmed Bug

List item breakage in IE8

Reported by: Michael Camden Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.2
Keywords: IE8 Cc: mcamden@…

Description (last modified by Jakub Ś)

Test environment, IE8 - Windows Vista (Problem does not occur on Windows 7)

After moving an existing list item down, and deleting that move, the list item does not correctly return to it's original position.

Steps to reproduce:

  1. Access ckeditor.com/demo
  2. Create three paragraphs, and turn them in to list items.
    • Item 1
    • Item 2
    • Item 3
  3. Place your cursor before Item 2, and press the enter key. This will create an empty item between Item 1 and Item 2. You should have four total items, with one empty one.
    • Item 1

    • Item 2
    • Item 3
  4. Again place your cursor before Item 2, and press the backspace key 2 times. The bullet for Item 2 is removed, and Item 2 is placed below the empty item.
    • Item 1

    • Item 2
    • Item 3

It seems that this process will orphan the Item 2 text outside of an LI tag. If you look at the editor source, you will see...

<ul>

<li>

Item 1</li>

<li>

&nbsp;</li>

Item 2 <li>

Item 3</li>

</ul>

Ideally this will behave as it does on Windows 7 IE 8. In that environment Item 2 will merge back in to the empty item.

Change History (3)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE8 added; ie8 windows vista removed
Status: newpending

Could you double-check it again? In my tests I have got the below result:

<ul>
	<li>
		item1</li>
	<li>
		&nbsp;</li>
</ul>
<p>
	item2</p>
<ul>
	<li>
		item3</li>
</ul>

List was split in two lists and 'item2' was placed in paragraph. This result is consistent between all versions of IE.

All other browsers put item2 back to its original place. So the only thing wrong I see here is inconsistent behavior between browsers.

comment:2 Changed 7 years ago by Michael Camden

Hello,

I have confirmed this is happening on a separate computer, using Windows Vista. I have taking a screen recording of the error and uploaded it to my website, http://michaelcamden.me/capture-1.avi

comment:3 Changed 7 years ago by Jakub Ś

Description: modified (diff)
Status: pendingconfirmed
Version: 3.63.3.2

I'm sorry I have made a mistake in point 4 where BACKSPACE should be actually pressed two times instead of one.

Issue has been reproducible in Win Vista and XP in IE8 from CKEditor 3.3.2

As you can see 'item2' text is out side li tag:

<ul>
	<li>
		item1</li>
	<li>
		&nbsp;</li>
	item2
	<li>
		item3</li>
</ul>
Last edited 7 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy