Opened 8 years ago

Closed 7 years ago

#8450 closed Bug (duplicate)

Pasting a list with sublists only indents first sub-list (3.6.1 and up)

Reported by: jorp Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.6.1
Keywords: Cc:

Description

I attached a test document with a simple nested list. Please paste the list into a ckeditor field.

Expected Results: Item 1 and Item 3 sublists should be indented.

Actual Results: Only Item 1 sublist is indented.

The behavior worked fine in 3.6.

Attachments (1)

nested-list-test.doc (21.5 KB) - added by jorp 8 years ago.
Test case

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by jorp

Attachment: nested-list-test.doc added

Test case

comment:1 Changed 8 years ago by Jakub Ś

Component: Core : ParserCore : Lists
Keywords: lists removed
Status: newconfirmed

Pasting lists got broken somewhere between rev [6909] and [6913].
Those revisions don't work so I can only guess, based on a comment, that has happened in [6911].

Probably form rev [6911] list was pasted without indentations (was flat). You can verify it looking at samples from rev [6914].

From rev [6977] when list from the above doc was pasted its "item 2" was missing but all the other elements were indented.

From rev [7008] result is the same as described by @jorp - only first element gets indented.

comment:2 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is actually a duplicate of #8103

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy