Opened 8 years ago

Closed 8 years ago

#8451 closed Bug (invalid)

Background-repeat: no-repeat - twice issue

Reported by: turalaliyev Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I've created mini content management system for workers of small company. This management system works with CKeditor. The ssmall group of users create new page with CKeditor (it's WYSWYG) and submit data into db.

Now the problem is, there is a css issue. Take a look at this page http://smiths-heimann.az/?page=171 and here are the results

The result from Google Chrome 14 http://i.stack.imgur.com/12MNb.png

Opera 11

http://i.stack.imgur.com/D7tUX.png

IE 9

http://i.stack.imgur.com/vKaol.png

and Firefox 7

http://i.stack.imgur.com/5GLx4.png

How to fix that problem on Firefox? There are hundreds of page with this problem in mysql db table. Is there anyway to find and fix wrong css code in db table with php function? How to fix this error in CKEdior 3.6?

[1]: [2]: [3]: [4]:

Change History (1)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: background repeat removed
Resolution: invalid
Status: newclosed
Version: 3.6.2

If you are seeking advice please use one of our forums http://cksource.com/forums/ and not system used for reporting CKEditor bugs.

As you have pointed out in the summary this is because you have used property - background-repeat: no-repeat no-repeat; for your pages which Firefox treats as invalid (The same is for IE6 - IE8). Property in form background-repeat: no-repeat; should be used instead.

Is there anyway to find and fix wrong CSS code in db table with php function

I don't know in what form those pages are kept in your DB but you should write the script that searches through the code and replaces background-repeat: no-repeat no-repeat; with background-repeat: no-repeat;

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy