Opened 8 years ago

Closed 7 years ago

#8477 closed New Feature (fixed)

Complete translation for French language (fr.js)

Reported by: Katryne Chauvigné-Bourlaud Owned by: Anna Tomanek
Priority: Normal Milestone:
Component: UI : Language Version: 3.6.2
Keywords: Cc:

Description

Here is my completed translation of the French main language file for CKeditor. It was just integrated in the new release of The CMS Guppy 4.6.17. And I wanted to propose a langage pack completely translated.

I hesitated a little about the translation of "tuples" on line 126, for I am no coder. Generally, it stays untranslated in French text. But When it is translated, we find sometimes "multiplet". But I choose to translate with the expression "couples de valeur".

Can you tell me how I can compress the file in order to include it in a language pack for Guppy ? I remember I did it once for FCKeditor,but I found no information about it for CK and it may be complicated for me. Or perhaps you could compress it for me ?

Are there any other language file in Ckeditor that would need localization, for instance in plugins ?

Best regards from Katryne Chauvigné-Bourlaud

Attachments (2)

fr.js (25.0 KB) - added by Jakub Ś 8 years ago.
New completed and corrected French language file for CKeditor 3.6.2
How to update release with new language file version.doc (31.5 KB) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

I have corrected the fr.js file as it had 2 errors. Entries with single quotations inside like remove : 'Supprimer l'ancre' should be written remove : 'Supprimer l\'ancre'.


Are there any other language file in Ckeditor that would need localization, for instance in plugins ?

There are 6 plugins that may need localization - a11yhelp, devtoools, placeholder, *specialchar*, uicolor (All those have lang directory but no fr.js file inside)


I have attached doc file explaining how can you include your file into release.

Changed 8 years ago by Jakub Ś

Attachment: fr.js added

New completed and corrected French language file for CKeditor 3.6.2

comment:2 Changed 7 years ago by Katryne Chauvigné-Bourlaud

Thank you j.swiderski,
I am sorry to have missed my 2 errors. I will try to pay attention in the future. I read again and again your help document about including new translations in a ckeditor release. But to no avail : I am no coder, only a little translator. And it seems really difficult for me.

Since I want only to modify existing lang files (not create any for a new language, at least at for the time being), would it be possible to compress only the language files and replace existing files in the pack with them ? In other words, is there an easy way of compressing one file and insert it in the pack, without compressing the whole lot ? Are the language files independant from other files ? I f so, they could be compressed individually ?
Thank you in advance for an answer in plain words. Katryne

comment:3 Changed 7 years ago by Jakub Ś

What you need is to minify (read remove blank spaces) your modified version of fr.js.
Such file should be then inserted under ckeditor\lang folder.

The easiest way is to:

  1. download code for CKEditor from SVN,
  2. copy your modified language files to _source/lang folder,
  3. double click on ckeditor_trunk\_dev\releaser\release.bat (if you are using windows).

Your minified files will be placed under ckeditor_trunk\_dev\releaser\release\release\lang

You can use either use created release or copy the language files to the release your client is using.

comment:4 Changed 7 years ago by Jakub Ś

@Katryne what you need is to apply the instructions from the first page. I have corrected it a little bit.

Installing Tortiose SVN is as simple as installing any other application for Windows. Please give it a try.

comment:5 Changed 7 years ago by Katryne Chauvigné-Bourlaud

I did it !!!! Thank you for being so patient. Now I can ask for the other languages (11 alltogether, including English and French) and will start with the plugins, first in French.

comment:6 Changed 7 years ago by Katryne Chauvigné-Bourlaud

Last edited 7 years ago by Katryne Chauvigné-Bourlaud (previous) (diff)

comment:7 Changed 7 years ago by Anna Tomanek

Owner: set to Anna Tomanek
Status: confirmedassigned

comment:8 Changed 7 years ago by Anna Tomanek

Resolution: fixed
Status: assignedclosed

Fixed on 2011-11-24 in CKEditor UI Translation Center at Transifex.

The changes will be ported back to trunk within 24 hours and will appear in the Nightly Build.

Thank you for your help, Katryne, and have fun with further translations at Transifex!

PS: "Couples de valeur" for tuples seems completely valid in this context, I think.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy